Strange thing is happening during deployment which is that deployment is getting failed in Sandbox 3 and getting successful in other sandboxes(Sandbox 1 and Sandbox 2)!



*********** DEPLOYMENT FAILED ***********
Request ID: 0Af1100000uURFe31AH

All Component Failures:
1.  permissionsets/AjayGupta_System_Administrator_Light.permissionset -- Error: duplicate value found: <unknown> duplicates value on record with id: <unknown>

*********** DEPLOYMENT FAILED ***********

If anyone has faced this problem, please help me. Your help will be appreciated.

Many Thanks!

  • Have you tried to retrieve the permission set metadata from sandbox 3? You might have it already created in there, no? – Renato Oliveira Oct 28 '15 at 12:21
  • It is already created but we have changes some permission in ps and we are trying to deploy that delta changes only using ANT – Ajay Gupta Oct 28 '15 at 12:53
  • Is it the same case for sandboxes 1 and 2 then? If it is, then you really have a situation there. You might want to try to backup the existing permission set (using ant, also), delete it in sandbox 3, and then try to deploy your new permission set. – Renato Oliveira Oct 28 '15 at 15:05
  • No for sandbox 1 and sandbox 2 it is working absolutly fine. And i dont want to delete the ps set. Could you please suggest any other solution intead of recreating it. – Ajay Gupta Oct 28 '15 at 16:02
  • I have no idea what else to do. I suggested backing it up before deleting it so you wouldn't lose your original data. Other issues like yours, reported in this same site, suggests that this might be caused by a History Tracking setting. But I don't see how this would be applied to a permission set, since it is not a custom object. But I think it is worthy to see if there are objects in the sandbox 3 that have this option enabled, and see in the other sandboxes if this is enabled as well. – Renato Oliveira Oct 28 '15 at 16:14

I got solution after some hit and trial method. Below two field permissions in the permission set were the culprit. I removed them from original file and pushed the code again and deployment is now successful in sandbox3 as well and all other sandboxes.


But still not able to understand the reason behind that, so please comment if anyone is aware about this situation?

Still very curious to know the reason...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.