enter image description hereData Import Wizard doesn't show custom field of a custom object.

All the fields have its Field level security set for Admin Profile. even though i cannot see fields in native import wizard. i have 7 fields among which only 2 are automatically mapped other are not visible

I haven't created a tab for the custom object, will it be a issue.

Please let me know which part i'm going wrong. Thanks in advance.

  • Check Field accessibility, it should not be hidden.
    – C0DEPirate
    Commented Oct 26, 2015 at 7:45
  • Its not hidden in the pagelayout
    – kishore
    Commented Oct 26, 2015 at 7:50
  • 1
    For all the 5 fields i have Field Accessibility to Editable .
    – kishore
    Commented Oct 26, 2015 at 8:04

10 Answers 10


I had the same problem and I have found a solution. The new Data Import Wizard picks the default record type and page layout as the controller for the visibility. You need to go to the profile and check what is the default record type and check if that record type page layout has the custom fields visible.

It worked for me.

  • it didnt work for me changing the defualt record type, but it worked when i added into the other page layout, just in case it helps anyone else
    – manza
    Commented May 24, 2019 at 4:21

This is a known issue listed on salesforce site



The Data Import Wizard uses page layouts and field-level security to determine the fields available on import.

In order for a field to be visible within the Data Import Wizard, it must be available to the user within the page layout and field-level security. This applies to end users as well as users with a System Administrator profile.


Go to the field and click on this button for the field and check it should be editable for the profile you are using.

enter image description here

For the auto-mapping your column name in CSV file should be same as Label or API Name of field

  • For all the 5 fields i have Field Accessibility to Editable.
    – kishore
    Commented Oct 26, 2015 at 8:03
  • You are saying, it is not auto mapped, are you not able to map them manually as well?
    – C0DEPirate
    Commented Oct 26, 2015 at 8:07
  • I am not able to view the fields itself.
    – kishore
    Commented Oct 26, 2015 at 8:08
  • Please look into the snapshot
    – kishore
    Commented Oct 26, 2015 at 8:10
  • Can you attach screen shot of columns in CSV file and fields you are trying to import in salesforce, also check datatype of those fields
    – C0DEPirate
    Commented Oct 26, 2015 at 8:13

Fields must be visible to the profile of the logged in user. Click on the fields that are not visible and click on the View Field Accessibility Button and check against the profile of logged in user, it should not be hidden.

  • This was the error causing my issue in a scratch org. Commented Oct 28, 2019 at 18:54

I had same issue with lookup fields. I went back to the Import your Data into Salesforce step of the wizard and mapped these lookup fields to the data type here and they were then available to map on the next page.

  • This appears to be essentially the same as Alberto Del Rio's answer from 4.5 years ago.
    – Derek F
    Commented Dec 10, 2020 at 20:36

What has not been mentioned here is that on the page where you select Add or Update. You must scroll down the page to select the appropriate record type.

This solved the problem I had.


Updating/Checking the profile and field level security for editable permission is not sufficient for some reason you need to make it visible on the page layout as well.


You can select Record Type under Add/Update options in the Data Import Wizard. That would open up more options available for a specific record type which could be missing on your default profile record type.

  • Welcome to Salesforce Stack Exchange (SFSE)! Your contribution is appreciated, but this appears to be essentially the same as @Tunde 's answer from almost 1 year ago. Can you please explain/expound on how your answer is different?
    – Moonpie
    Commented Apr 1, 2022 at 12:14

If it helps anyone in the future: If this problem is only for NON Admins, then a setting in the profile called 'Import Custom Objects' (setup--> profile --> system permission --> Import Custom Objects) can also help.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .