6

Unfortunately, I get the following error while try to save changes to a class,

Failed to create createContainerMember for containerId=1dc19000000BE6AAAW: This container member belongs to a container that currently has an unfinished save request with deploymentId=1dr19000000e9gQ. You may not modify any members in this container until it completes.: Metadata Container ID

I tried the solution mentioned here Developer console cannot save classes/triggers/pages though it worked for the first time and then the trick stopped working.

Anybody has a solution for this?

3 Answers 3

9

Try going to the the Progress Tab in the Developer Console and click on Cancel all deployments. This worked for me.

Failed to create deployment: This container has a save in progress with deploymentId=[YOUR-DEPLOYMENT-ID]

0
3

Create a new Developer Console workspace. From the Developer Console, select Workspace > New Workspace. Enter a name for your new workspace, and then click OK.

Delete your corrupted workspace: a. From the Developer Console, select Workspace > Workspace Manager. b. Highlight your corrupted workspace. c. Click Delete

1
  • Thanks. I also just closed the developer console with the file unsaved, reloaded it and then was able to save that way.
    – Jim Factor
    May 6, 2018 at 2:05
0

I was facing the same issue. It was happening because of a recent system refresh. My previous profile got changed due to it hence I lost access. So, please check if there have been any recent changes in your User. Also, Please check if you have sufficient privilege to make changes.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .