7

I'm working on Lightning Components which should be used it a Community created by the Community Builder. This gives me a very hard time to debug the components as described here: What is the best way to debug Lightning Components (used in the Community Builder)?

Best thing I got is the suggestion from @MohithShrivastava to create a separate Lightning app as a wrapper for a component during development-time like this

<aura:application>
  <c:ToBeDebuggedComponent/>
</aura:application>

Then in the app the JavaScript errors should pop up as usual in the browser's console.

As an unfortunate I'm running form one issue into another. The first error I got was that it's required to have a MyDomain (though I haven't activated the critical update yet). I registered and deployed that MyDomain.

Now I got the next error

An error has occurred in the following section: [Exception, DomainNotPropagated]. Salesforce.com has been notified of this error.

enter image description here

I understand that DNS entries might take some time to propagate - but it's now a couple of hours ago and still the same.

Any idea on what needs to be done to finally be able to get clean error logs into my console?

7

This is an error or misconfiguration on Salesforce's side - at least it was in my case. You should open a support-case and refer to this link and maybe my case number (12670479).

They have resolved the issue and replied this

Hi, Hope you are doing well. This is to inform you that I was able to get in touch with Tier 3 to enable a permission so that Exception, DomainNotPropagated error can be fixed. Tier 3 has done this now and it is working as expected. Please inform if you need any other help. Thanks. Regards Developer Support Tier 2

Hard to say what that means exactly, but it works now...

  • These issues are occurring because Winter '16 requires Domain registered for Salesforce instance to operate custom lightning components. Most of the instances don't have domain registered. Salesforce having issues with it. – Ashwani Oct 23 '15 at 17:11
  • There was a bug where lightning subdomain registrations failed in sandboxes for some (hopefully short) period. That's fixed, but from what I saw there wasn't a good way to fix impacted orgs automatically, hence the need for T3 to fix it by hand. – ca_peterson Jan 30 '16 at 1:22
2

Please refresh your page after 2 to 5 minutes. Error gets resolved. This error seems that recenlty you have defined your domain name.

  • This is true normally - but in the scope of this question totally wrong. We (and others) were waiting for days and the error persists. Without Salesforce support taking action, we would've been waiting for ever.... – Uwe Heim May 11 '16 at 6:59
  • 2
    For people looking for answers for scratch orgs, this answer worked for me. I just refreshed after a couple of minutes. – SamuelDev Dec 19 '18 at 1:56
  • yep. in context of scratch orgs it works! – Seyitbek Apr 23 '19 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.