3

enter image description here

Hi everyone,

I am trying to implement ExactTarget from SalesForce MobilePush and encountered a problem. Inside the static library contains ET's sqlite and at the same time my app is also using custom sqlite library. Here is the error log shown (duplicate symbol). What would be the ideal solution to this?

3

Dsw,

Essentially this means that you're trying to include Sqlite3 twice. The Marketing Cloud SDK requires Sqlite3, but there's nothing to say you can't piggy back on it. Essentially remove your sqlite3.a file from the project and that should resolve it for you.

Additionally, you can get this error if you accidentally import the .m file, instead of the .h file. this bit of shell voodoo will help you find the offending line/file if this is the case:

grep "import.*.m" **/*.[hm]

| improve this answer | |
  • Hi Kevin, thanks for your answer. If I need to include my own version sqlite (because it is custom) - do I have another choice? – Dsw Oct 27 '15 at 3:09
  • DSW, Not really. You'll either have to namespace your instance of sqlite or (maybe) use a wrapper like fmdb to namespace it for you. What kinds of customizations are you doing to sqlite3? the Marketing cloud's version may already include those enhancements. – Kevin P Oct 27 '15 at 18:55
3

We've been making improvements to our SDK; please see

https://salesforce.stackexchange.com/a/131089/34325

for details on the changes we'll be releasing to support this use case.

Brian M. Criscuolo, Senior Mobile Engineer

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.