2

I'm trying to install this free component provided by Salesforce https://appexchange.salesforce.com/listingDetail?listingId=a0N30000000qD5VEAU into a brand new Developer Org (Partner Developer Edition) located on EU5.

As an unfortunate after logging into AppExchange and clicking on the green "Get it Now" button, I get only

Oops! Looks like you don't have permission to install apps.

To keep your Salesforce secure, only system administrators have permission to install apps or components. Please contact your Salesforce system administrator to install this app or component.

Or if you're feeling adventurous, sign up for a new free trial of Salesforce so you can install and try out the app or component on your own.

enter image description here

However I'm pretty sure to be Administrator on the Org (I'm the one and only Admin-User on the Org and have spun it myself...)

Any Idea on how to get this component installed is welcome!

  • Does that org have a custom My Domain enabled and deployed? – pchittum Oct 20 '15 at 10:11
  • @Peter no, I have no custom My Domain enabled. Is that required? I would prefer to go without for many reasons... – Uwe Heim Oct 20 '15 at 10:20
  • As of Winter 16, My Domain is required for every org, for any custom Lightning Comonents feature: developer.salesforce.com/blogs/developer-relations/2015/10/… – pchittum Oct 20 '15 at 10:22
  • Granted, that error is not very helpful. Can you capture the failure error for me in a screen shot and email it to me, @UweHeim. I'd like to suggest we make that failure error more intuitive. – pchittum Oct 20 '15 at 10:26
  • Shoot. Kind of a shot in the dark on my part. Is that all the information the failure gives? Can you install using API deploy? (Same user, same source/dest orgs.) – pchittum Oct 20 '15 at 12:46
1

It looks like this component is obsolete to be installed from the AppExchange, because in the description it says:

Filter List is a standard Lightning Component available in Lightning App Builder. No need to install - find it in Lightning App Builder in Setup. Easily display records from standard and Custom Objects from any list view.

If this interpretation is right and in order to avoid confusions, Salesforce should do one of the following:

  • remove that listing OR
  • remove the "Get it now"-Button OR
  • provide a meaningful error-message
0

In Winter 16, for purposes of increased security, we now require a custom My Domain fourth-level domain for any org using custom Lightning Components functionality.

This information is in the release notes.

The developer relations team also blogged about it recently.

  • Unfortunately after enabling and deploying the my Domain, there is exactly no change in the result. I still get the same error messages (plus I'm kind of unhappy with the my-domain itself, but what wouldn't we do all for security) – Uwe Heim Oct 20 '15 at 11:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.