1

Okay, I know this is a very specific question, but maybe someone out there can help:

BACKGROUND: I have modified the original custom code for a "Mass Edit" button so that:

{!REQUIRESCRIPT("/soap/ajax/20.0/connection.js")}
{!REQUIRESCRIPT("/soap/ajax/20.0/apex.js")}

var records = {!GETRECORDIDS($ObjectType.SelfSufficiency_Evaluation__c)};
var strIDs='';
if (records[0] == null)
{
alert('Please select all of the Domain records for the Client in order to input scores');
}
else
{
for (var n=0; n {
if(strIDs == '')
strIDs = records[n];
else
strIDs = strIDs + "," + records[n] ;
}
window.location.href = '/apex/MassManager__MassEdit?selectedRecords='+strIDs + '&selectedObject=SelfSufficiency_Evaluation__c&selectedFields=Domain_Type__c,Intake_Score__c,X30_Days_Post_Birth_Score__c,X90_Days_Post_Birth_Score__c,Exit_Score__c,Aftercare_Intake_Score__c,X6_months_Aftercare_Score__c,X12_months_Aftercare_Score__c,X18_months_Aftercare_Score__c,X24_months_Aftercare_Score__c&retURL='+ window.location.href;
}

Basically this custom button allows us to mass edit the custom fields listed towards the end on the code.

QUESTION: Is it possible to make the first custom field "Domain_Type__c" read-only via javascript? Already tried via page layout but didn't work, hence my question.

Thanks!

  • 2
    Have you tried making a formula field that is essentially the value of Domain_Type__c then using that field in your URL instead of the Domain_Type__c? I do not use that package so not sure if you can trick it like this or not. – Eric Oct 12 '15 at 19:33
  • @Eric Unfortunately, even though the formula field is "read-only", it still shows up as "editible" in the rendered mass edit screen. – Jake Schmitz Oct 16 '15 at 23:09
  • Hmmm. They must be doing custom inputs or something as a formula field is never editable – Eric Oct 16 '15 at 23:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.