7

I'm trying to access Salesforce from an Android Tablet(version 5.0.2) and it redirects me to the full site instead of s1 app.

Last week it was working fine and I was able to access Salesforce1 app with the same configuration.

I have the following error message today: You can't access Lightning Experience

I have tested the same using an Android smartphone (Xperia Z3) and works as expected accessing s1 app.

I'm only using 1 user for all this testing.

Salesforce configuration:

  • User: Salesforce1 User Enabled
  • Salesforce1 Settings: Enable the Salesforce1 mobile browser app Enabled
  • Lightning Experience Disabled (because we're happy with aloha ui)

Chrome mobile browser:

  • Request desktop site Disabled

Is anyone else facing the same issue?


Edit: Updates

Salesforce has come back with the following answer, it didn't solve my problem but maybe it can solve someone else's.

You will first need to follow the article below and make sure the checkbox for the Dkestop view is not checked: http://www.cnet.com/how-to/how-to-request-desktop-version-of-a-web-site-in-chrome-for-android/ Once you have this check box unchecked then login and if you are still not in Salesforce1 then follow the document below to switch to the proper view: https://help.salesforce.com/apex/HTViewSolution?urlname=How-to-switch-between-Salesforce1-app-and-Full-Site-on-a-mobile-browser&language=en_US Use the second screenshot.

  • I think it is the issue with the browser user agent that is being sent. Since tablet will not provide debugging tools, it will be hard to find out. There is a post on Salesforce about this issue. help.salesforce.com/… I understand that the post says about desktop browser however user agent string helps in identifying the browser type and mode – manjit5190 Oct 12 '15 at 15:38
  • Can you clarify, are you getting this error when going to Salesforce in the browser on the tablet, or are you using the Salesforce1 native app downloaded from Google Play Store? – Christian Carter Oct 12 '15 at 15:48
  • But I'm getting the same error even if I tried to access via one/one.app @ChristianCarter : I'm using chrome browser in the tablet, It's not allowed to install any app in these tablets. Company security policies. – Vrakmhare Oct 12 '15 at 16:27
2

I wrote a blog post to address this http://www.oyecode.com/2015/10/winter-16-fix-salesforce1-oneoneapp.html

But caveat is all sandbox which are in cs22 works with this workaround. But cs21 are failing

@R&D - Fix it please

1

Looks like your org has been updated to winter 16 release and not sure if it is officially documented ,

In your browser if your device is not supported please enable lightning experience .

Enabling lightning will not mean your org will be affected unless you assign permission sets .So safely enable lightning and you should be able to access the app from all devices or even in browser via one/one.app

  • Thanks for your answer. I've tried enabling lightning in the org and not to the user and it's failing anyway. And when I tried to access via one/one.app I got the following error: "Lightning Experience is enabled for your organization, but not yet for you" – Vrakmhare Oct 12 '15 at 16:20
  • Weird that it works for me .Anyways raise a case with SFDC and check with them whats this all about . – Mohith Shrivastava Oct 12 '15 at 16:34
  • Yeah, it's really weird. I raised a case as you suggested. I don't want to assume I have to enable lightning experience to this user just yet. Thanks! – Vrakmhare Oct 12 '15 at 16:52
  • 1
    Here is how you can do it : recordit.co/4H5qHkDcqp – Harshit Pandey Oct 27 '15 at 7:22
  • 1
1

So Salesforce HelpDesk has answered this with the following information:

this issue has been identified as Bug by our R&D team and they are currently working on it to fix the issue which will be delivered in the future releases. Unfortunately we don't have an exact time frame for release of the bug fix yet.

So it should work without enabling Lightning Experience and it only happen with Android Tablets.

Thanks all for the help!

0

As of Winter 16, you cannot access Salesforce1 via the browser without Lightning enabled. If you don't want to go down the LEX route, you need to use the native app.

To enable the Lightning Experience, you need to follow the instructions on the LE setup tab. It involves both enabling it for your org, and also assigning permission sets to the users who you want to be using it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.