2

Has anyone encountered issues creating a new project through the MavensMate-app? It just keeps on loading. It just displays the message "Creating new MavensMate Project" for hours together. Please provide solution if anyone has figured it out.

Thanks, Sriram.

3

As per the GitHub site https://github.com/joeferraro/MavensMate-app, they have packaged the local MavensMate server into a nifty, cross-platform application called MavensMate-app. Why did they do it? Quite simply, to make it easier to install and run MavensMate. All MavensMate plugins (Sublime Text, Atom, etc.) now require MavensMate-app to be installed and running in order to function properly.

So download and install the app from here https://github.com/joeferraro/mavensmate-app/releases according to your OS version.

Now got to (SublimeText) MaventsMate > Settings > User Pluggin seeting and update mm_mavensmate_app_location to the MavensMate-app installation path.

In MavensMate-app global settings(can be found in the MavensMate-app menu) change the mm_workspace to your mavensmate workspace folder.

Now you can user your MavensMate from SublimeText. Hope this helps.

|improve this answer|||||
  • I have updated it already but of no use, it still takes forever to create the project. – Sriram Lns Oct 5 '15 at 13:42
2

After the recent updates to the MavensMate-app, Mavensmate.exe needs to be running while trying to update a project, otherwise it will throw the error:

"Could not contact local MavensMate server, please ensure MavensMate-app is installed and running."

Go to your C:\Program file.. \ mavensmate \ mavensmate.exe and run mavensmate.exe.

I use the v6 and it works well.

|improve this answer|||||
  • I am already using v0.0.6, problem is it takes forever to create a new project. I have waited nearly for 2 hours and still project was not created in my local workspace. I have updated the workspace location and logs location and also mm_mavensmate_app_location in SublimeText. – Sriram Lns Oct 5 '15 at 13:41
  • Did you check mavensmate global settings? The workspace, etc.. need to be updated in global settings. They are on mavensmate-->settings, Or Are you behind a proxy? Make sure that you have just the basic components in package.xml? I prefer to first try in my dev Org which has a very few components. A large project takes a while for me. – Shruthi Oct 5 '15 at 23:52
  • I have already taken care of the pre-requisites like the global settings and so forth. No proxy and also trying to import only Apex classes and Pages from my Sandbox env - its not so huge. Anyways thanks for the advise, I will try to remove everything and re-install. – Sriram Lns Oct 6 '15 at 15:10
0

I don't know if you have fixed this, but I got similar problem which got solved really easy.

The thing is that the default path given in the package user control is

"mm_workspace" : "/Users/WTF/Desktop/Application/",

After I just added the drive volume (C:) before the line, it "magically" worked : ))

"mm_workspace" : "C:/Users/WTF/Desktop/Application/",

I hope this ridiculous fix will solve the issue :)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.