7

Opened a case with Salesforce, but thought this issue could use some exploration.

Recently, in two of our sandboxes (one dev pro, other is full, one CS9, the other CS11), deployments via the force.com migration tool, the developer console and mavensmate deployments are taking inordinate amounts of time (15 minutes at times that the deployment remains "pending"), even for deployments of a single class/page or through the developer console. This has been persistent for a week now, and the symptoms appeared in the full sandbox after a deployment of components from the dev sandbox.

What could possibly cause this? I'm guessing it's something that Salesforce is having difficulty compiling, but I'm not aware of any way to measure the performance of component compilation.

  • Taking 10 minutes right now on cs4. – tggagne Apr 8 '16 at 20:06
3

We have also been experiencing this on CS30 and possibly CS16. Working offline it sits pending on the synchronize check for minutes on end before it finally gets to deploy and then sits pending for minutes longer. I have on several occasions over the last couple days had it timeout which I believe is 10 minutes.

Like you, this is often just a single class that I happen to be working on. Even with the size of the codebase we have, it would normally only take a minute or less to save a class.

I can't speak to the developer console, but this is definitely happening to us in both the Force.com IDE and ANT. This seems to be possibly related to the Tooling API.

PS: Forgot to mention that we also opened a support case for this issue.

  • 1
    What was the resolution of the case you logged? – Jorjani Dec 7 '16 at 21:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.