2

I'm using an ETL tool Talend for data push to salesforce. When I'm upserting the accounts getting the error below In the mapping I specified the business accounts recordtypeId but still is throwing the same error.

1.What is the cause for the error?

2.Do I need to add anything else other than the recordtypeId to differentiate the Business Accounts and person Accounts?

Error:

Exception in component tSalesforceOutput_1
java.lang.Exception: Cannot specify any additional fields when marrying or separating a Person-Account

at org.talend.salesforce.SforceManagementImpl.upsert(SforceManagementImpl.java:481)
at salesforceetl.sync_accounts_0_1.sync_accounts.tMysqlInput_1Process(sync_accounts.java:2841)
at salesforceetl.sync_accounts_0_1.sync_accounts$2.run(sync_accounts.java:19166)
ERROR: export_salesforce_client -> Accounts: Cannot specify any additional fields when marrying or separating a Person-Account
-- null records rejected. Please check error log file workspace/log/sync_salesforce.sync_accounts.loaderrors.log
5

When changing record types from business to person you cannot specify any other field values.

I believe what is happening is that you are trying to populate the record type of a BUSINESS account with the value of the Person account record type along with the other fields and this is not allowed.

Or alternately you are trying to change a person account of one record type ID to another person account record type ID...

Basically the change of the recordType ID cannot include any other field values

| improve this answer | |
  • I made sure that no mappings to the person account fields. Also I have hardcoded the business account Recordtype Id. But still getting the same error I think the issue is the Name field that I'm using to map the Account Name. If I try to remove the Name from mapping it say the required field name is missing. I made no access to consumer record type to API user still same error. Is there a way to stop this person accounts? – Salesforce Learner Oct 7 '15 at 19:48
  • @SalesforceLearner - Can you post a few line of the csv as well as the operation you are trying to perform? – Eric Oct 7 '15 at 21:05
  • @ Eric:Thanks a lot. I got the issue I'm trying to update a person account with the business account fields so that makes the records to fail. – Salesforce Learner Oct 12 '15 at 17:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.