1

Hello I am trying to connect the heroku postgreSQL database from mulesoft but unable to connect it. The error I am receiving is

java.sql.SQLException: FATAL: no pg_hba.conf entry for host ....... ssl off.

error description

The steps I followed to create the connection from Anypoint Studio (Mukesoft) added postgreSQL9.3-1101.jar and used a global connection for connecting with the heroku postgres database. Next in the configuration I have stated the url as "jdbc:postgresql://<host>.compute-1.amazonaws.com:5432/<database>?password=<password>&user=<user>?ssl=true&sslfactory=org.postgresql.ssl.NonValidatingFactory" and added the org.postgreSql.Driver as driver class name. But when I am trying to test the connection it is giving me the above error. As suggested in some of the heroku documentation I have also tried to append "?ssl=true&sslfactory=org.postgresql.ssl.NonValidatingFactory" to the end of the DATABASE url but with no success. So any help how to solve this issue would be greatly appreciated.

  • Was this issue resolved? I am getting the exact same error and can't figure out what to do. Any help please? – Srini Dec 22 '16 at 18:45
0

Normally

ssl=true

should do the trick to bypass IP checks in pg_hba.conf file.

Please ensure the pg_hba.conf has the default content.

protected by Community Aug 30 at 7:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.