After going to a session at Dreamforce where they demo'd Files Connect for Google Apps, I'm now trying to setup Files Connect in our sandbox so I can try it out myself. I've followed the instructions in the salesforce help.

First, setup a permission set that allows assigned users to use Files Connect for Cloud (https://help.salesforce.com/HTViewHelpDoc?id=admin_files_connect_perm.htm&language=en_US)

Next, setup an auth provider for Google Drive (https://help.salesforce.com/HTViewHelpDoc?id=admin_files_connect_google_auth.htm&language=en_US#topic-title)

Next, setup an external data source for Google Drive (https://help.salesforce.com/HTViewHelpDoc?id=admin_files_connect_google_xds.htm&language=en_US#admin_files_connect_google_xds)

Finally, go to a user and assign them the correct permission set.

After I do this, I would expect to login as the user who was assigned the permission set. Go to make a Chatter post and click File > Select a file from Salesforce and then have an option on the left menu for Google Drive. However, I do not get this menu item for Google Drive.

So, I went to the global search and typed in a phrase. Then clicked search all on the left side of the results screen. There's a section named items_RapRec_Google_/. I clicked that and it gave me a Salesforce error (which I can't reproduce at the moment to give the exact message). It said something to the effect of your user isn't authorized. I had to add my user to the external data user authentications of the External data source I had setup for connecting to Google Drive. That sent me to a Google Auth screen (yay!), then I went back to the search screen to try searching again, and now I get an error message that says We encountered this error while searching RapRec_Google_Apps_Drive: You don't have permission to access this external data source. Contact your Salesforce administrator for assistance.

I'm not sure what to try from here. I'm stumped. I'm hoping someone else can point me in the right direction.



I went back to Dreamforce videos to the session I attended at Dreamforce that only showed how to USE files connect and found the name of the guy who did the presentation. Thankfully he has a video in YouTube that shows the setup process. It can be found here: https://www.youtube.com/watch?v=pSN7H8CPp-Y

The step I was missing in setup was after you create the permission set initially that allows users to Use Files Connect Cloud, you have to setup the auth provide, the external data source for Google drive. AFTER that, you also have to go back to your permission set and then go to External Data Source Access and (now that it's been created) enable that external data source to be used when users are assigned this permission set.

Everything works as it should now. Hope that helps someone down the road.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.