3

I am updating the Case page layout and cannot figure why some Quick Actions show up, but others do not. The top image number 1 shows which quick actions I have chosen to add to the page layout. Image number 2 shows that only the Email and Log a Call actions are actually showing up. I can get some other actions to appear, such as Files and Communities. There is simply no rhyme or reason for what is happening.

I have a System Admin profile and the org is the Summer '15 version.

edit: I am trying to add the "Send Email" quick action which is on the Case object (not global). The native "Email" quick action is able to be added without issue. I am making these changes on the Case object page layout.

enter image description here

enter image description here

3 Answers 3

3

Actions are contextual. If it doesn't apply to the page and context of the page, it may not appear. I don't know exactly what your Actions do and whether they're Global or Object Specific Actions. Which one of those they are would make a difference. Knowing more about what the Action does, the object it acts upon, and whether it's Global or Object only would be important to know.

Object Specific Actions need to be added to the Salesforce1 Action Bar while Global Actions do not. In my experience, sometimes you may need to clear your browser cache on your mobile device before you'll be able to updates to your Action Bar.

Finally, you may also need to be on the Object Specific Page before you'll see the Action become available since it will need to come into context. Also, if the Action is only intended to work in the Community, you'll need to log in as a Community User in order to see it.

6
  • @crmproddev thanks for the quick reply; I added clarification to the original post.. Still not sure why it won't display. Sep 22, 2015 at 15:49
  • Did you add the "Send Email" Action to the Salesforce1 Action Bar? That's where an Object-Specific Action needs to be added.
    – crmprogdev
    Sep 22, 2015 at 15:53
  • It's there, too.. but it's still not showing up. Sep 22, 2015 at 16:05
  • Did you see my note about possibly needing to clear your mobile device's cache? I'm talking about it's browser btw. Also check SF1 cache too. I don't recall for certain which it was, but have had similar problems with needing to clear caches before updates like this would finally take.
    – crmprogdev
    Sep 22, 2015 at 16:28
  • Will these quick action buttons ONLY display on mobile? I need it to show up on my PC. I tried two separate computers and a handful of browsers. Sep 22, 2015 at 18:30
0

Solution is to make sure that your user have the right access. => for creating a record check if the profile allows it and if the correct record types are assigned to the profile.

-2

I encountered the same issue (on a different object) and solved it by enabling feed tracking for the object.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .