2

Last week I had problems with saving files through Dev console, sometimes it got stuck on save requests so I had to delete workspace, create new one save again etc. The other solution was through Eclipse Force.com IDE. It worked but now it is not saving anything again. First error I encountered was:

Unable to patch container member.: This container member belongs to a container that currently has an unfinished save request with deploymentId=1drj0000001SlvU. You may not modify any members in this container until it completes.: Metadata Container ID

Second was this one:

Unable to patch container member.: 1drj0000001Slve is not a valid containerId.

Of course, I submitted a case to SF but they said the request is out scope and that we need to pay Developer premium support in order for them to help us. Does anyone have any idea or has anyone encountered similar problems before?

This is something like a recurring event. It happens every two months (roughly) and lasts for 1-5 days. We didn't have any feedback about possible causes and solutions to this error so far.

  • did you ever find a solution to this? I have the same problem about 2x a month. – Olivia Jan 5 '17 at 19:11
  • I think creating new developing environment and deleting old one solved the problem for some time. BUT, if I recall correctly, problem was also with error in code that we overlooked, and Dev Console didn't identify... – luciferche Jan 9 '17 at 9:44
4

I was having the same problem in the developer console. I performed following steps and it worked for me. Probably it will work for you too.

  1. Open the developer console and try to save.
  2. Copy the Container Id you are getting as error and in a new tab open this URL: https://instanceURL.salesforce.com/containerId
  3. Delete that container.
  4. Now close that class/trigger/page in developer console. (Do not close the developer console)
  5. Now open the class/page/trigger again and try saving it
  • Not sure if this works or not but upvoting to thank you for taking the time to post this. Sometimes these issues are so difficult to solve so thanks for posting – Eric Sep 21 '15 at 14:39
  • Thanks. I will write this down. I am not sure if it helps because Dev console is back, working properly, but after this many days lost due to similar problems, i am sure I will give it a try next time this happens. I tried everything else that i could think of and that I could find online but I didn't see this approach. Thanks a lot. – luciferche Sep 21 '15 at 15:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.