I'm trying to open custom url scheme iOS app from Salesforce1 app. Previously it was opening fine but since v7.3.1 release i cannot open external app anymore.

Instead of opening app it opens Salesforce1 page with error text:

you can't view this page, either because you don't have permission or because the page isn't supported on mobile devices.

Tried this solution: https://salesforce.stackexchange.com/a/30368/24640

Prevous version of salesforce was working fine when using:

window.top.location = 'myapp://'


iframe.src = 'myapp://'

At the moment I'm not sure than if this is bug or salesforce changed something.

  • tried also use not recommended sforce.one.navigateToURL but no success
    – Piotr
    Commented Sep 11, 2015 at 13:28

2 Answers 2


I've managed to run app using a bit different link:

window.top.location = 'myapp://home';

It need to be something after schema and before query string like in my example.

I think salesforce1 is validating a link and if it's empty after schema it throws an error.


Just added target="_blank" to my URL and the app pulls up again.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .