12

Has anyone else noticed that the Debug Logs in the Developer Console are becoming notoriously unreliable? I am finding that often when I run code through Execute Anonymous in the hopes of examining the resulting Debug Log, none is generated there, even if it shows up in Logs > Debug Logs. I have tried switching around my Workspace and some other strategies, but it seems really inconsistent as far as I am able to observe.

UPDATE

From what I can tell, the most reliable fix for this issue is to instantiate a Debug Log for the running User (Setup > Monitor > Logs > Debug Logs).

migrated from meta.salesforce.stackexchange.com Sep 9 '15 at 9:13

This question came from our discussion, support, and feature requests site for Salesforce administrators, implementation experts, developers and anybody in-between.

  • 1
    At least you can get the Dev Console to open. I've got one Dev Org that when I open the Dev Console for it, it causes the entire org to freeze today (NA16)! (sigh) – crmprogdev Aug 17 '15 at 21:36
  • 3
    I notice this, minus the log actually showing up under the Debug Logs page in setup. Once I set the monitoring on myself, the logs start re-appearing in the console. However, I do find that this is unpredictable behavior, as sometimes I won't have any monitoring set but the logs may be showing in the console. At this point, I always have a tab open on the Debug Logs page with the reset URL on my user id... – kbentsen Aug 17 '15 at 21:48
  • 1
    I've been struggling with this one today. Every time I update the vf page or controller I'm working with, I seem to need to close and reopen the developer console in order to get it to listen to the event log again. Frustrating. – pchittum Aug 18 '15 at 13:50
  • 1
    Yes editing files also seems to break it for me. – Adrian Larson Aug 18 '15 at 13:51
  • 2
    I also have this problem. It seems like debug logs expiring in developer console. When I check log levels I usually see 2 out of 3 logs to be expired and in red while 1 log is either on time (now) or expired also. Changing time greater than now on a log fixes the problem temporarily but it always resets itself after some time. – tugce Sep 1 '15 at 7:29
3

I'm not sure if this is the same issue, but if you go to Debug > Change Log Levels.. you may see that one or more items have expired.

For me, if I set the Expiration value to a time later than now, the debug logs start working again.

2

I wanted to post this link to a KB article titled Why do I receive a script error when trying to execute the Developer Console? I found which may or may not be helpful to those who are trying to troubleshoot problems with their Dev Consoles.

The IDEWorkspace is accessible through Workbench using the REST explorer. If you have the Id of the IDEworkspace, you can view the contents of your IDEworkspace and delete any problematic contents. Support tells me the first thing to do with problematic Dev Consoles is to delete ALL logs. When I did that, it didn't work for me, but might for others. More importantly, the article suggests to me that there's much about the Dev Console that can be explored by various means if one has the knowledge, time and interest.

In my experience, if the Dev Console won't open, you want to try to delete the history of what it's trying to put in the console for you in the default view from the last session. That was the issue I was having from having been working with Lightning components. I couldn't get a debug session going in the child window to even obtain the Id of my workspace (Chrome browser). What eventually worked for me, was repeatedly trying have a Lightning component file open up in the Dev Console from the list of components in setup that I'd already created. Eventually, that cleared out the corrupted history of what should open up by default in the console, allowing the console to open for me with the file I'd selected.

Hope this helps someone else with any issues they're having.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.