When I try to login into data loader, I get a login error. I am sure that I am using the correct username and password, but I am still unable to login.

  • What was the error message ? Sep 4, 2015 at 8:34
  • Error logging into salesforce. Please check your username and password Sep 4, 2015 at 8:35
  • you are login with developer org credentials or sandbox org credentials? Sep 4, 2015 at 8:37
  • I am testing with a developer org Sep 4, 2015 at 8:42
  • Do i need to change some settings on data loder? Sep 4, 2015 at 8:43

5 Answers 5


The two most common problems are:

  1. You need to either:

    • Add append a Security Token to the end of your password. The security token will be emailed to you if you reset it from My Settings > Personal Information in Salesforce.
    • Add your current ip address to your user profile. If you don't see the button to reset your security token, it is likely because your user profile has ip restrictions set up. If you go to Setup > Manage Users > Profiles > Your Profile > Login IP Ranges, you can add your ip address to the list, and you will be able to login to the Data Loader with just your username and password, without having to add a security token.
  2. You are logging in to production or a developer environment instead of the sandbox (or vice-versa) and you need to change the target url to login.salesforce.com (or test.salesforce.com) in the data loader settings.

  • 1
    How about adding a 3rd - failing to append the security token to the password?
    – Keith C
    Sep 4, 2015 at 8:47
  • 1
    @KeithC That was part of my #1. Being at a white-listed ip range can "make up" for not having a security token, so since you only need one or the other, I put them together as a single issue.
    – martin
    Sep 4, 2015 at 8:55
  • Woops I should have read the whole sentence. Or the sentence should start with adding the security token.
    – Keith C
    Sep 4, 2015 at 9:17
  • @KeithC good point. It would make sense to lead off with the security token.
    – martin
    Sep 4, 2015 at 9:47

When using the Data Loader, you need to set the server host to be:

  1. https://login.salesforce.com for Production and Developer environments, or
  2. https://test.salesforce.com for Sandbox environments.

You can find this under Settings:

enter image description here


if you are facing this error "Failed to send request to https://www.salesforce.com/services/Soap/u/31.0", then add proxy details if you are using private domain as shown below screenshot dataloader proxy


Probably silly but the password has to be password + security token.


  • I tried everything but that did not work either Sep 4, 2015 at 10:37

I got the same/similar issue as while trying to connect to salesforce using Apex Dataloader.

Got a total of 2 issues while trying to connect, after resolving the first one.

  1. Error "Error logging in to Salesforce. Please check your username and password."

  2. Error" TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to Salesforce using https"

1) For the 1st issue please do below You will need to reset your security token before following the instructions below. To reset your security token click Setup > My Personal Information > Reset My Security Token. Then click the "Reset Security Token" button on the resulting page. After that you will receive an email with your security token and some instructions very similar to these... How to enter your security token: If your password = "mypassword" And you security token = "XXXXXXXXXX" You must enter "mypasswordXXXXXXXXXX" in place of your password Remember that these security tokens are for tools like the data loader but not for use on the standard Salesforce.com login page.

2)For the 1st issue please do below Need to deactivate the "Require TLS 1.1 or higher for HTTPS connections" under critical updates in Salesforce. Please follow the instructions provided by salesforce itself Clik_here

After this I was able to Export/Import records in & out of Salesforce without any issue

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .