1

I'm using custom object Employee__c and I have added a new field called type = picklist for State when I go to the page to create a new records the picklist (State) shows in disabled mode and I do not see I have any Field Dependencies or Validation Rules. So what might be the case?

here is the sample of the State picklist.

  <fields>
    <fullName>State__c</fullName>
    <externalId>false</externalId>
    <label>State</label>
    <picklist>
        <picklistValues>
            <fullName>Alabama</fullName>
            <default>false</default>
        </picklistValues>
        <picklistValues>
            <fullName>Alaska</fullName>
            <default>false</default>
        </picklistValues> 
        //more.....
        <picklistValues>
            <fullName>California</fullName>
            <default>false</default>
        </picklistValues> 
        <sorted>false</sorted>
    </picklist>
    <trackHistory>false</trackHistory>
    <trackTrending>false</trackTrending>
    <type>Picklist</type>
</fields>
7
  • I would suspect field level security or page layout. Can you double check those? Commented Sep 3, 2015 at 1:49
  • in the field level security i have all checked to visible and what exactly I will be looking in the page layout?
    – Nick
    Commented Sep 3, 2015 at 1:51
  • For picklist to be editable on field level security you should have read only unchecked. Regarding page layout, open the page layout -> go to the field -> click on the wrench -> make sure read only is not ticked. Commented Sep 3, 2015 at 1:55
  • read-only is not checked ... not sure what else do I need to look
    – Nick
    Commented Sep 3, 2015 at 1:57
  • 2
    Does the object has a record type? Is there any value selected for that particular record type? Commented Sep 3, 2015 at 3:35

1 Answer 1

0

Here is how I fixed my issue

The reason why it was disabled is because there was no values selected.

Steps:

  1. Go to the Custom Object (you having issue with) and View the Record Types
  2. Click on the Record Type Label
  3. Click on the field (having issue with) from the PickList Available for Editing
  4. Make sure the Selected Values have some values selected
  5. Repeat if you have more than one Record Types

In my case there were no Selected Values selected.

Hope this will help others.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .