1

Our team is having an issue saving classes/pages to the server through Force.com IDE. It is an org-wide issue and not connected to their credentials/IP access/profile/API rights/connectivity issue.

Restarting Eclipse/laptops, creating a new project, cleaning the project, cleaning cache(DNS,system,user) are some of the ideas we tried and didn't work. Any thoughts?

Screenshot from Mac.

We also see the following error in the logs:

"Unable to get authorization info - endpoint is null or empty"

  • Turn off the Firewall in Mac's Privacy and Security settings or allow eclipse through it. – Ashwani Aug 24 '15 at 17:53
  • Firewall was off and we still have the issue – Jorjani Aug 24 '15 at 18:09
  • Everything was working perfectly until Sunday and all of a sudden, we are having this issue. – Jorjani Aug 24 '15 at 19:36
  • I have following configuration working: Force.com IDE plugin version 33.0 installed on Eclipse Juno. OS X 10.10 Yosemite. Java: Apple legacy java runtime and JDK 7 update 8 installed. This is working fine for me on LAN and WiFi – Ashwani Aug 24 '15 at 19:42
  • One more question: is it for one org or all orgs? – Ashwani Aug 24 '15 at 19:44
2

Right-Click on the project name in Eclipse -> Force.com -> Project Properties -> Force.com

We had set the environment to Production/Developer, which was redirecting to www.salesforce.com instead of login.salesforce.com (Not sure how that was changed). We selected "other" and specified login.salesforce.com as the host.

You cannot login to www.salesforce.com. It must be a salesforce subdomain.

0

I am having the same issue on Windows 7 / Eclipse Kepler. Sandbox orgs seem to work ok. Have a case into salesforce.

  • Look at my answer above. – Jorjani Aug 24 '15 at 21:00
  • 1
    Back in business - thanks for posting your answer. I think something changed on salesforce's end and not in eclipse since I had a browser bookmark to get to the login page using something like: www.salesforce.com/login.jsp?un=xxx@xxx.com which stopped working at the same time of the eclipse issue – user7524 Aug 25 '15 at 0:40
  • Looks like salesforce fixed something. I am now able to create a project against an org using the regular production/developer setting which was not working yesterday without the manual host work-around – user7524 Aug 25 '15 at 15:22
  • We tried it yesterday and it looks like production/developer looks at login.salesforce.com after you change it once manually. So I think it's Eclipse being smart, not SF fixing something. – Jorjani Aug 25 '15 at 15:47
0

Very first check for any active firwall/antivirus software into your network.

If there is active firewall/antivirus software, then deactivate/disable it.

And then try.

If issue still persists then try it by changing your network. You can use any netsetter or any different service provider internet.

It may help you out.

-2

There is a problem with SF and their IDE API on some orgs. We see this on Eclipse and on MeavenMate too. We've opened a case to salesforce.

This has been fix

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.