2

I am trying to follow the directions here:

https://help.salesforce.com/apex/HTViewHelpDoc?id=connected_app_create.htm

I click "Setup" and I create a new app. But I do not see any link offering me the option "Enable OAuth Settings". I've spent 45 minutes looking for this link, and reading various articles, all of which make it sound as if this would be easy to find. But I feel like what I see on screen is different from what is being described.

Where is Enable OAuth Settings?

If I go to edit the app, I see these fields:

App Label

App Name

Description

Choose the Image Source for the Custom App Logo

Choose the Tabs

Overwrite Users' Personal Custom App Customizations

Default Landing Tab

Assign to Profiles

but nothing about Oauth.

1

From your description, it sounds as though you're missing a very important step. After you go to Setup, click Create | Apps, you need to 2. In the Connected Apps section, click New. What you're doing only applies to Connected Apps. The information you enter will then apply to the following basic parts:

  • Basic Information
  • API (Enable OAuth Settings)
  • Web App Settings
  • Mobile App Settings
  • Canvas App Settings

The description you've provided has been as though you were creating a new Salesforce App, not a Connected App. See the following page for more on OAuth for Connected Apps.

  • Hmm, well, that is a different way of doing things -- that process takes me through 5 different menus, but none of them mention Oauth or an API. And I end up here: na34.salesforce.com/…, and I see my new app listed under "Apps" but under "Connected Apps" it says "No Apps found." – larry_rollio Aug 14 '15 at 14:51
  • Hmm, if I click "New" by "Connected Apps" then I see the menus that are described in the articles. This link to "Connected Apps" is deeply buried. – larry_rollio Aug 14 '15 at 14:52
0

I did the same thing.

@crmprogdev's answer is good but it didn't fully get me there. Here are the steps I would have needed to seen to find it.

First of all, all of this is assuming you're using Salesforce Classic. Not the new Lightning.

  1. Find your name in the upper-right, click the down-arrow, click Setup.

Salesforce classic Setup dnder your name

  1. In the upper-left, click "Quick Find / Search", type in "apps". Choose "Apps" under App Setup / Create. Ignore "Connected Apps" that also appears.

Salesforce classic quick find Create Apps

  1. Do not get excited and immediately fooled by the first "New" button you see. Apps are not Connected Apps. I know, who could possibly be confused by this? Choose New under the Connected Apps section.

Salesforce Classic New button under Connected Apps not New button under Apps

  1. This is what you're looking for.

Salesforce Classic New Connected Apps screen including Enable OAuth Settings

I hope these steps saved someone an hour.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.