1

This piece of code returns FALSE in a Group edition organization owned by a customer, and I'm unable to figure out why. When tried in a brand new GE org provisioned via EnvHub, it works properly.

AFAIK GE doesn't support custom profiles, org wide sharing settings, etc.

What could have been done on this organization for this check to fail?

(Code is delivered via AppExchange package).

    return !(Schema.sObjectType.Contact.isCreateable() &&
            Schema.sObjectType.Contact.isUpdateable() &&
            Schema.sObjectType.Contact.Fields.FirstName.isUpdateable() &&
            Schema.sObjectType.Contact.Fields.LastName.isUpdateable() &&
            Schema.sObjectType.Contact.Fields.Title.isUpdateable() &&
            Schema.sObjectType.Contact.Fields.Phone.isUpdateable() &&
            Schema.sObjectType.Contact.Fields.Email.isUpdateable());

What practices can be used when troubleshooting managed package issues in a GE?

1
+50

I found Access Control in Group and Professional Editions

"Because field level security is handled by the page layout, any fields you want to be visible must be added to the page layout. This means that for fields to be accessible via the API or Visualforce, they must be added to the page layout."

Can you confirm that all the fields you want to access are on a page layout.

  • Yes, all the fields are in the Contact layout page. :( – BuddhiP Aug 14 '15 at 16:40
  • I take that back. I thought all the fields were in the layout, but looks like I was wrong. – BuddhiP Aug 15 '15 at 4:22
  • @BuddhiP OK. Let us know what happens when all the fields you are referencing are added to the layout. – Daniel Ballinger Aug 15 '15 at 7:22
0

There are some stuff that you can do to check -

  1. Put debug in managed package and try to run it
  2. Check if actually the profile who is trying to run this is having permssions
  3. Try to run the package code in a dev org whether it works, if it works then you know fir sure the issue is with edition of org
  4. Try requesting with Salesforce support to enable debugging on client org where you can check complete debug.
  • I can't install a managed package unless I publish it to AppExchange since this is a GE (right?), 2. tried that, 3. Code works in dev orgs, other editions, and also in other Group editions, only one organization causes the issue. 4. I do not have developer support from SF :( – BuddhiP Aug 14 '15 at 16:43
  • 1. You can install packages even if it is not part of AppExchange, try adding debug to your code and create a new Beta package and then run it on affected org. – Kaushik Ray Aug 15 '15 at 3:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.