1

Good Day!

I am trying to create a WebTab Or VS page to display given web link which displays a Map based on Openlayers. There is no interaction intended between salesforce and the map at this point. (The Web link to display: "http://52.27.83.144/GMSC/public/peelchildcare/") I tried creating a WebTab without any merge fields but no avail. Then I tried creating a Visual force page using the code below, tried even downloading the JS and CSS file as static resource but cant figure out whats wrong. Please help! (thinking if creating as Lightning component will help ?)

CODE BEGINS:

<apex:page sidebar="false" showHeader="true"  standardStyleSheets="false" controller="ChildCarePublicController">
 <html>
<head>
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0" />
    <title>peelchildcare</title>
       <apex:stylesheet value="/resource/smartPublicMaps/ig.publicmaps.application.min.css" />
        <script src="https://52.27.83.144/GMSC/Public/Content/Scripts/ig.publicmaps.application.min.js"></script>

     <!--    <script src="<a target="_blank" href="" rel="nofollow">https://52.27.83.144/GMSC/Public/Content/Scripts/ig.publicmaps.application.min.js"></script></a>-->


    <script type="text/javascript" id="PublicMapsApplication">
        IG.PublicMaps.application = {"site":"GMSC","projectId":"d74f8831-7ab0-4122-8b41-84980daa73d9","projectName":"peelchildcare","defaultMapViewId":"8b1b832d-8689-437d-94fa-07d5e4fc1c1a","mapViews":[{"id":"8b1b832d-8689-437d-94fa-07d5e4fc1c1a","name":"PeelChildcare","bounds":{"left":-8926829.96,"bottom":5383941.42,"right":-8849031.03,"top":5465620.59},"copyright":null,"center":{"x":-8887930.5,"y":5424781.01},"zoomLevel":"15","isDefault":true,"baseMap":{"type":4,"config":{"zoomLevelCount":20}},"hasMapLayer":false,"hasPoiLayer":true,"hasSearch":false,"searchHint":""}],"symbols":{"90be6f63-bde1-4955-acc7-c9768c33278e":{"isScaleDependent":false,"dimension":{"width":11,"height":11},"dimensions":null}},"baseUrl":"http://52.27.83.144/GMSC/Public/","language":"en-US","isRightToLeft":false};
    </script>
    <style>
#map {
font-family: Arial;
font-size:12px;
line-height:normal !important;
height:250px;
background:transparent;
}
</style></head>
<body ontouchstart="">
    <!--<div> -->
   <div id="ig-publicmaps">

</div>
    <!--</div> -->
</body>
</html>
</apex:page>

CODE ENDS

1

I figured out that it was the SSL layer and digital certificate not configured and PORT 443 to be opened. Once that done and changing the HTTP to HTTPS made it worked all fine.

Thanks for your time!

  • Glad you got it figured out. Can you close this question? – Kris Gray Aug 5 '15 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.