2

Anyone have already encounter this issue? Error will occur if you select the any of the picklist. Any other way to fix the issue?

VisualForce Page

<apex:page showheader="false" sidebar="false" standardController="Task">

     <apex:form>

     <apex:inputField value="{!Task.WhoId}" />
     <apex:inputField value="{!Task.WhatId}" />

    </apex:form>
</apex:page>

JS ERROR

Uncaught SyntaxError: Failed to execute 'querySelector' on 'Document': '[secid=j_id0:j_id2:j_id3_mlbtn]' is not a valid selector.

EDIT : Adding Screenshot for reference

enter image description here

  • when do you get this error ? when saving the VF page or when running it ? I tried the exact same code in my dev org and it works fine. – Vamsi Krishna Jul 29 '15 at 4:08
  • @VamsiKrishna running in VF page. open your google chrome developer console and you will see the JS error. – Marvz73 Jul 29 '15 at 4:10
  • This error may be coming from a browser extension. Turn off all your browser extensions (via Window -> Extensions in Chrome) and see if the error stops. – Keith C Jul 29 '15 at 7:46
  • @KeithC I already did but the error still the same. – Marvz73 Jul 30 '15 at 1:40
  • In the Sources tab, hit the Pause on Exceptions button so we can see what line is causing it. You could have features on that others dont so it would really help to know whos doing that line. – Kris Gray Aug 9 '15 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.