3

I tried to separate person account by changing record type from person account to business account as advised in this question:

final Account acc = [SELECT Id, recordtypeid FROM Account where id = '001c000000o9d17' LIMIT 1];
acc.recordtypeid = '012D00000006gD2';
update acc;

001c000000o9d17 is a person account, and 012D00000006gD2 is a business account record type. I've got the following error:

 first error: INVALID_PERSON_ACCOUNT_OPERATION, person-account cannot be separated.: []

I remember that change of record type worked in previous releases, but it doesn't work in a newly created Sandbox (with Summer 15 release). Googling "person-account cannot be separated" doesn't help a lot (seems like it is either a newly introduced error message, or nobody faced it before).

Is "person-account cannot be separated" error a Summer 15 new feature?

  • Are there any field updates happening via workflow rules? If so try disabling them. I read once that the record type change operation could not be done with any other type of field update – Eric Jul 19 '15 at 15:03
  • I've checked - no workflow rules in the system – Kos Jul 19 '15 at 19:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.