2

I am trying to increase the test coverage and it keeps failing and few of the useful debug log statements from my test class are not showing up and below are the ways I tried:

1):

System.debug(LoggingLevel.ERROR, '###The CaseSObjList size is '+ caseSObjList.size());

2):

Overridden the debug log filters on my test class as shown below:

enter image description here

But nothing is working and it shows this message

*********** MAXIMUM DEBUG LOG SIZE REACHED ***********

and does not log much after that..Here is the screenshot.

enter image description here

Is there any other setting that I need to do use so that only the debug log statements from my test classes are printed and not from any of the other classes/triggers/validation rules/workflows.

If there is a option, I would like to turn off even the logging of managed package debug logs.

Thanks in Advance!

This is driving me crazy..as I am not able to figure out why my test is failing.

  • 1
    In the dev console just set everything to error.... – Eric Jul 17 '15 at 21:34
4

In the dev console just set everything to error

1

So you can turn off the debug log for all other classes, but it would be hard, you'd have to adjust the log settings for every other class individually.

I've encountered this myself, and it's typically due to the number of test methods in the test class. In order to get details about the particular test that was failing, I comment out all other test methods, and then run the tests, which resulting in a small enough debug log I could see the details about the failing test.

  • Thanks Ralph. I got it..I need to turn off the logging of each and every class( manually) that my test method is invoking in its execution stack. – javanoob Jul 17 '15 at 21:43
  • 1
    Well I'd start with commenting out in other test methods in the class that has a failure first. If you have a debug log that is long to exceed the limit my guess is there are quite a few apex classes. – Ralph Callaway Jul 17 '15 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.