Just realized an issue with some of my code coverage. I've been using Quick Deploy quite a lot lately and haven't seemed to have any issues -- my triggers have good code coverage in the sandbox (85-100%) and pass the validation deploy, so I use Quick Deploy and everything's great.

Thing is, I just noticed that most of the triggers I've deployed this way are showing 0% code coverage in production. They show full code coverage in the sandbox, and passed totally fine -- so I think the only issue has to be with the Quick Deploy process.

Has anyone else had this problem? I'm unsure if it's a Quick Deploy bug, or a failure on my part. Wanted to ask around before I create a case.


  • What results you get after when you "Run All Test" in production?
    – Ashwani
    Jul 16, 2015 at 14:28
  • I assume the tests that cover the triggers in the Sandbox are a) in production already or b) in the deployment set?
    – Matt Lacey
    Jul 17, 2015 at 7:25

2 Answers 2



1) You have to re-compile all the classes/triggers - "Compile all Classes" link on Apex Classes page. (i.e.) You need to make sure "Is Valid" check box on Classes and Triggers pages to be checked/enabled.

2) You need to execute "Run All Tests" to get the code coverage for the components back.


Please clear the Test Data/ Test Execution History before proceeding to the steps listed above. Thanks @Enreeco

  • 1
    I whould also suggest a Setup > Apex Test Execution > View Test History > Clear Test Data Jul 16, 2015 at 14:37
  • 4
    Yes. This should be the first step before what I listed. Thanks @Enreeco . Let me update the main answer with this information, as it gets the broader audience.
    – Vignex
    Jul 16, 2015 at 14:42
  • Perfect, sorry for the delay but thank you Vignex!
    – mlpSFadmin
    Jul 28, 2015 at 18:52

This is the random behavior from Salesforce. Though if we compile all classes still its not working.

Please suggest some more options.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .