1

I followed the instructions on this page https://help.exacttarget.com/en-US/technical_library/web_service_guide/technical_articles/retrieving_all_subscribers_on_a_list/

however the answer I get contains all the subscribers on all the lists, it does not seem to be filtering at all. Here is the soap body I am using, can someone look and see if I am missing anything:

  <soapenv:Body>
<ns2:RetrieveRequestMsg xmlns:ns2="http://exacttarget.com/wsdl/partnerAPI">
  <ns2:RetrieveRequest>   
    <ns2:ObjectType>ListSubscriber</ns2:ObjectType>
    <ns2:Properties>ID</ns2:Properties>
    <ns2:Properties>Client.ID</ns2:Properties>
    <ns2:Properties>CreatedDate</ns2:Properties>
    <ns2:Properties>ListID</ns2:Properties>
    <ns2:Properties>ModifiedDate</ns2:Properties>
    <ns2:Properties>ObjectID</ns2:Properties>
    <ns2:Properties>Status</ns2:Properties>
    <ns2:Properties>SubscriberKey</ns2:Properties>
    <Filter type="par:SimpleFilterPart" xmlns:par="http://exacttarget.com/wsdl/partnerAPI">
         <Property>ListID</Property>
         <SimpleOperator>equals</SimpleOperator>
         <Value>18618078</Value>  
     </Filter>
    <ns2:ContinueRequest></ns2:ContinueRequest>
    <ns2:QueryAllAccounts>true</ns2:QueryAllAccounts>
  </ns2:RetrieveRequest>
</ns2:RetrieveRequestMsg>

1 Answer 1

0

There is an issue with the XML namespaces used in your call. Notice the Filter tag doesn't have "ns2:" in it like the rest of the tags in that node. Due to this issue, the Filter tag is being ignored.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .