0

I added some new fields to my custom picklist and then deployed it with the user profiles. Unfortunately in my target org, the picklist values don't show up as an option. When I go to setup I can see they are there, but on the detail page I cannot select them. I am not sure how to make them available and how to avoid this in future deployments.

Thanks, Lily

  • 2
    Are you using record types with that object to control picklist values? – Girbot Jul 15 '15 at 6:37
  • 1
    Or, if they're for the Lead Status or Opportunity Stages, have you added the new values to the Lead Process / Sales Process? – Alex S Jul 15 '15 at 6:45
3

Since this is custom picklist and values are available in setup and not on page, this makes clear that you have multiple record types configured on this object.

In this scenario, adding a picklist value is a two step process. In Step one you actually add the value and in step 2 you assign the value to appropriate record types.

Deployment ensured that the values are configured now but since step 2 was not complete, values are not assign. Kindly go to the record types for this object. On clicking on it, it will display all picklists. Edit the corresponding picklist and enable the values.

For future deployments, ensure that picklists and record types are included together. Follow this article for more details - https://help.salesforce.com/HTViewSolution?id=000206546&language=en_US

  • Thanks! How can I deploy this properly in the future? do I need to deploy record types as well? – Lily Jul 15 '15 at 9:30
  • That is correct. I have updated answer with more details. – Amit Bangad Jul 15 '15 at 9:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.