2

Hi what does this setting mean? When checked, I can go to test.salesforce.com in safari and see Salesforce1 version of the sandbox i.e. the feed, apps etc. But when open Salesforce1 directly, I see the full site version.

So I uncheck this option, then when open Salesforce1 directly, I see the Salesforce1 version. But when I go to test.salesforce.com in safari, I see the full site version.

I want my users to use Salesforce1 version by downloading Salesforce1 app so I will need to turn this setting off then? Any advice on how to use this setting properly?

1

From SF Help: Turn the Salesforce1 Mobile Browser App Off or On page:

If you disable automatic redirection to the Salesforce1 mobile browser app, you’re turning off automatic access for any supported browser, on any of your mobile devices. For example, if you turn off the mobile browser app from your tablet, you won’t be able to use the mobile browser app on your mobile phone either.

These steps don’t affect the Salesforce1 downloadable apps which always display the Salesforce1 interface.

Also,

To turn off the mobile browser app from within the app:

Tap Navigation icon.

Tap Full Site.

  • When the setting is off, I can actually see the full site page but the lookup links do not work. – user4402671 Jul 9 '15 at 17:50
  • This setting does affect the Salesforce1 app itself. When this setting is on, I see the full site version if I open the Salesforce1 app. I have to turn this off to see the Salesforce1 version in the Salesforce1 app. Hope that makes sense. – user4402671 Jul 9 '15 at 17:56
  • Yes. The setting is related to viewing the site from an ipad or other HTML5 mobile device browser without using the Salesforce1 App. As I mentioned at the bottom of my post, Salesforce1 turns the full site browser on and off internally. It's all explained in the link I provided. – crmprogdev Jul 9 '15 at 18:00
0

Yes unchecking "Salesforce1 user" option only answer to your requirement. as after unchecking if a user open salesforce in mobile browser, it will open in full mode not in SF1 mode.

  • This doesn't really answer the question, though. – sfdcfox Jul 8 '15 at 15:18
  • oh sorry, yes i didn't read it properly. correcting it – Ankuli Jul 8 '15 at 15:24
0

The "Salesforce1 User" setting only controls the behavior for the browser-based application (one/one.app).

If you have the Salesforce1 User setting ON:

  • User will be redirected to the Salesforce1 interface automatically when using a supported mobile browser.

  • User will see the full site interface if they use any other browser.

If you have the Salesforce1 User setting OFF:

  • User will land on the full site interface when using any browser, mobile or otherwise.

In both scenarios a user can force the Salesforce1 interface in a browser by adding /one/one.app to the URL.

This should have no affect on the behavior of the Salesforce1 downloadable application, which should never launch into the full site interface. Have you tested with multiple devices also? If this is happening I would verify that you are on a supported mobile device or check with Support: https://help.salesforce.com/apex/HTViewHelpDoc?id=sf1_requirements.htm&language=en_US

If you are on a supported device for the downloadable application I would verify that your OS is up to date, the Salesforce1 app is up to date, and the app has been fully restarted (double-tap on home button and swipe app up off screen for iOS as an example).

So again, this Salesforce1 User setting only controls which interface you see when you connect from a supported mobile browser. This has no bearing on the Salesforce1 downloadable app behavior which should never show the full site interface.

  • Another note, all of the Salesforce1 downloadable app settings are under Setup > Manage Apps > Connected Apps, then select the Operating Systems you would like to use (iOS, Android are separate connected apps). As long as the connected app is set to "All Users may self-authorize" then your users can download and log into the Salesforce1 app. If you have the permitted users section restricted you just need to ensure they have the correct profile or permission set to use the app. – Kalin Jul 8 '15 at 16:33
  • I'm actually referring to the Salesforce1 app itself. When the setting is on, I see Salesforce1 version in Safari browser. But when open the Salesforce1 app directly, I see the full site version? That's the part that I don't quite understand. – user4402671 Jul 9 '15 at 17:54
  • Yes, I do understand that you mean the Salesforce1 app itself. The setting we are discussing is specific to what UI will be shown in a browser and has nothing to do with what UI will show in the Salesforce1 app. The Salesforce1 app should NEVER show the full site interface, which is why I was saying it sounds like there is another issue at play. Have you ensured you are on a supported device and everything is up to date/restarted? Are you using the standard Production login setting with the Salesforce1 app? – Kalin Jul 9 '15 at 20:10
  • Also, what tab are you supposed to land on when opening Salesforce1? Do you have any custom code that may be redirecting you elsewhere on this tab? Improper navigation links in Salesforce1 have shown to launch the full site at times. – Kalin Jul 9 '15 at 20:42
  • I don't think unchecking the option will be helpful in any way. But I don't understand how I see the full site version in Salesforce1 app. Maybe because I had the option off and then turned it on. – user4402671 Jul 15 '15 at 21:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.