A [similar question] was asked here 1 Copying metadata and code from one Production org to another

and I have a twist on this...

Assuming there are two orgs, Prod1 and DE, or Prod1 and Prod2.

Assume I don't have access to Prod1, but I have a .zip file of Prod1's schema. Assume this was created via the Export... feature.

Has anyone tried to Import... a .zip file, open it up in a new Project, and then deploy that metadata to a new Server (Prod2 or DE)? That is, you're not able to connect directly to Prod1 to capture its schema.

I've been having trouble with a couple phases of this attempt: - using the wizards I can associate the .zip file to import but it seems like I have to have a new destination Project created first to tell Eclipse where to extract the zip - true / false? - if I manage to do some pasting to get the src folder into a Project, right-mouse-button clicking to go to Force.com >.... does NOT show a "Deploy to Server" submenu option. Instead of the 5-8 submenu options only 1 shows up.

3 Answers 3


You might find it a bit easier to avoid the eclipse and just use the Ant migration tool. http://www.salesforce.com/us/developer/docs/apexcode/Content/apex_deploying_ant.htm

Your .zip file from Org1 should contain the package.xml and all the contents you extracted, using that you can use the deploy feature from the command line to push it up to the target org (And avoid any confusion that you may be encountering with Eclipse).

A word of warning, you may not be successful, especially if your extract from Org1 was incomplete or if your target organisation contains a different set of enabled features than the source.

  • I agree 100%. In this scenario it will be much better to use the Ant Migration tool rather than trying to somehow import that into a Eclipse project. Feb 8, 2013 at 13:47
  • Exactly, package.xml is your friend - create project friendly manifest and use that to download and upload. However, as an aside I would recommend anyone doing builds have access to the environments involved.
    – joshbirk
    Feb 8, 2013 at 16:08

I have not explored this a lot, but I do seem to recall that a Force.com IDE project must have an active connection to its org to deploy correctly.

Have you tried using the workbench.developerforce.com Deploy feature? This is an external app, so you'll need to authenticate via OAuth, then go to Migration > Deploy.

If your zip is a correctly structured set of salesforce resources, with a package.xml manifest file, you should be able to point the deploy feature to it, and just deploy it.

The one gotcha is that it will attempt to deploy absolutely everything in the zip. But if that's ok, you should be good.


If you have SnapShot (http://appexchange.salesforce.com/listingDetail?listingId=a0N300000016YhyEAE), you can deploy what you need and scrub unnecessary profile references as part of the migration as well.

Disclaimer: I work for DreamFactory, the makers of SnapShot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .