6

One of our user noticed that the default Asset lookup field in the Case isn't displaying every Asset tied to an Account in our organization. I verified that there were no lookup filter preventing search, but even with no lookup filter, there's no way to search for certain Assets.

I tried with using the Admin account, but it is still not working. Any idea?

4
  • This sounds pretty strange, it might help if you posted some screenshots. Have you tried updating via apex to see if you get any error messages? – Ralph Callaway Feb 19 '13 at 0:02
  • 1
    This sounds like a sharing issue. Can the owner of the asset search for it in the lookup? And does it appear it you query it via soql as a system administrator? – Greg Grinberg Feb 20 '13 at 3:19
  • Yes it does appear in a SOQL request. I tried as Admin, not working. I can see them in the Account (and the users too), but cannot reach them from the lookup field. Sadly, I cannot provide any screenshot since the information is confidential... – jpmonette Feb 21 '13 at 15:08
  • have you tried searching for the asset in the lookup search box? sometimes you get the problem that the lookup window only displays recent assets. What you can also do is open the assets you can't find once, and then try the lookup again. – pjcarly Mar 9 '13 at 9:37
1

This is what I found in the SFDC help:

For the asset standard lookup on a case, the dialog shows all the assets tied to the contact on the case, if any.

So, if you have specified a contact in a case, the asset lookup will show you all assets that are related to the contact in the case.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.