2

I have a VF page that allows someone to create a record in a custom object 'Co_op_Fund__c'. When the page is viewed through the site, I see the labels and Save button but none of the fields are visible/editable. I made sure the guest site profile has all CRUD, even View/Modify All; Org wide security is public r/w on the object and I ran through FLS for all fields to be editable. Still for some reason I can't get the field values to display.

I feel like I'm missing some basic step but in all the years I've been combining VF with sites I haven't been stuck like this before. Any thoughts on where else to look?

<apex:page controller="PartnerCoopFundController" >

<apex:form id="form">        

                   <!-- error text section -->
                   {!pgErrors}
                <apex:outputPanel rendered="{!validContact}">

                        <table class="primary-acc-table edit-user-table" style="border: 0;">
                            <tr>
                                <td class="licenseTable">
                                    <div class="label">Activity Name</div> 
                                    <div class="content"><apex:inputField value="{!coop.Activity_Name__c}" styleClass="inputFieldsCustom" required="true"/></div>
                                </td> 
                                <td class="licenseTable"> 
                                    <div class="label">Activity Type</div> 
                                    <div class="content"><apex:inputField value="{!coop.Activity_Type__c}" styleClass="inputFieldsCustom" required="true"/></div>  
                                </td>
                            </tr>
... more rows of inputFields
                                <tr> <td rows="2"> <apex:commandButton action="{!saveRequest}" value="Save"  styleclass="cccBtn"  /></td></tr>                                                                                                                                                                                            
                        </table>
                </apex:outputPanel> 
    </apex:form>            

enter image description here

  • double check FLS for guest user profile .I can only think of FLS in your case – Mohith Shrivastava Jun 21 '15 at 20:04
  • 1
    Deployment Status! I was using an object my coworker created in sandbox and it was set to 'In Development'. Testing as an admin worked fine since admins can see objects in development but I guess the site guest user can't. – nikiV Jun 21 '15 at 20:12
4

It was the object's Deployment Status set to 'In Development'. Once it was set to 'Deployed' the sites page worked as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.