3

I am calling REST api to post lead. It works fine for Developer edition. My app has passed the security review and whitelisted by Salesforce. But when I tried to post to Group edition. I got his error:

[{"message":"No such column 'Website' on sobject of type Lead","errorCode":"INVALID_FIELD"}]

How can I detect a user's edition is group edition so I can't avoid Website column for the post?

1 Answer 1

4

This error is specific to a user that doesn't have access to a particular field. As far as I'm aware, Website is a standard field that appears in all editions that support leads (all but personal edition?). Most likely, the administrator removed that field from the page layout, which automatically revokes access to the field for all profiles in editions less than Enterprise Edition (or, rather, any org that does not have Record Types & Page Layouts).

Instead, you should always run a describe before attempting to use any field. You must not assume that a particular field is present or visible. It is acceptable to cache describes, though, and only pull a new describe when the user requests it or a new error occurs (e.g. another field was removed).

3
  • I just signed up a trial group edition. Website is not present in the Lead page. Can you please show me what is describe? or any docs about that?
    – angelokh
    Jun 19, 2015 at 22:11
  • 1
    @angelokh Check Setup > Customize > Leads > Page Layouts, see if you can add Website to the layout. As for documentation, it's in the REST API documentation under "REST API Reference > Reference > SObject Describe".
    – sfdcfox
    Jun 19, 2015 at 22:15
  • This is the product I am working on. We are providing our users a way to insert lead to their Salesforce. I can't change Page Layouts for them. But yes, for my own group edition trial account, I can see Website and add it to the layout.
    – angelokh
    Jun 19, 2015 at 22:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .