Today I encounter a severe performance degradation on Metadata-API deployment speed on EU5. I'm waiting > 950 seconds (sometimes > 1500 seconds), when it usually deploys in < 25 seconds...

This is NOT usable any more.

Any idea what's wrong on that Pod? On EU2 it works fine as expected. Only EU5 seems to be slow. On trust.salesforce.org there is no problem visible. My experience is, that Metadata-API issues are not all reflected there.

No premier support available - can't report that issue.

UPDATE (2015-06-18)

Not really sure if it's related but I found an earlier issue "related to asynchronious requests" which is flagged as "solved":

Start Time: 13:53 UTC, Jun 17

End Time: 14:16 UTC, Jun 17

Detail: On June 17 , 2015, the Salesforce Technology Team observed an issue affecting asynchronous request processing on the EU2 instance. The problem began at 13:53 UTC and was resolved by 14:16 UTC. During this time, a subset of customers may have experienced delays in asynchronous processing including Web-to-Case, Web-to-Lead, Email-to-Case, Email-to-Lead, and dashboard refreshes. Thank you for your continued business and patience during this situation.

Root Cause: Cause: The problem was caused by a software fault in the asynchronous queue management tier for the EU2 instance. Action was taken to isolate the fault and normal asynchronous request performance was restored.

Actions to Prevent Future Incidents: The Salesforce Technology Team - - Is investigating the cause of the software fault.

UPDATE (2015-06-19)

The issue persists. Today I tried to install 3 Managed Packages via ant. It took > 11 min (usually < 1 min). Deploying one APEX class took 882 sec (usually < 15 sec). Still no chance to report that issue, still no idea how to go on.

enter image description here


2 Answers 2


This is something that has been happening for a week or so on EU5 now. It looks like salesforce changed the way it process the metadata queues, I.E. From an Asynchronous to none-Asyncronous, Therefor the queue now works the same way as the other queues in the system. You will be getting placed into the queue with everybody else and just have to wait for others to finish. This is partly due to EU5 been a smaller instance server then others. If you wish to get around this issue change the user local in the org and you will get a new instance. deploy at a quite UK time (not 9-5, Mon-Fri) Or If you already have a deployment and are just trying to work, Use mavensMate and compile using APITooling.

  • Thanks Tim, Mavensmate is way too slow for me. It saves with toolingAPI never faster than 14 seconds. It's a while when I checked last, but it was a desaster: salesforce.stackexchange.com/questions/53060/…. Even Force.com IDE does it faster with ~8 secs. CodeFusion can make it < 4 secs for small files. But I can't use ToolingAPI here, because I have to deploy on a production instance - therefore ToolingAPI quits with an error. Only Metadata-API is allowed.
    – Uwe Heim
    Jun 17, 2015 at 16:35
  • 1
    Deployment is not usable this way - we have to deploy many (>200) times per day to test stuff on real data. No chance to do it with 900 seconds, No chance to do it on quite UK times, need to do it every day... need a solution.
    – Uwe Heim
    Jun 17, 2015 at 16:38
  • Tim, how does the trick with the locale work? Never heard that you can port an Org easily to another Pod. Something like higher approval was necessary and it took a very long and complicated process. Is this different here? Can I escape the EU5-coffin in a simple way?
    – Uwe Heim
    Jun 17, 2015 at 16:45
  • When you create your org (Dev orgs) The user will be assigned a local from your systems local. If you tell your Pc or Mac that you are in middle of Europe or America then it will create your org on a instance other then EU5. Jun 17, 2015 at 22:26
  • Unfortunately this doesn't help on clients production orgs. In that case there isn't an easy escape plan.
    – Uwe Heim
    Jun 17, 2015 at 22:52

Update 2015-06-24: like Keir said, we are crashing again with >900 seconds, still waiting... No solution. In my opinion EU5 is unfit for production use. Salesforce: please help or let us migrate to another pod. We can't go on like that. This issue seems not to be related to Patch levels. More and more it think it's the server itself. Hardware, Software or the new UK datacenter - who knows. The results are serious.

Update 2015-06-22: we are back to about 14 seconds which is typical for Metadata-API and small single files:

enter image description here

The core problem seems to be solved. However looking at trust.salesforce it seems like nothing ever happened:

enter image description here

Only thing is we know that we couldn't work for days... So it would be nice to learn which kind of issues are eligible to be reflected here and which won't show up.

  • Premier support haven't come back with anything useful I'm afraid - I reported it on Friday and they sat on it until Monday afternoon and then told me that they tried a deployment which completed in 19 seconds. The cynic in me is suggesting that they waited until the knew it was fixed before coming back to me, as this should have been investigated over the weekend. I'm running test deployments throughout today, as I saw the worst delays between 11am and 3pm. Jun 23, 2015 at 7:21
  • Something else that may or may not be related - EU5 was at patch 10.1 when I was hitting these problems last week, but its now at 10.2 so I wonder if a fix has been put in place. Jun 23, 2015 at 7:23
  • It doesn't look like its fixed - I've got single class save that has been stuck in pending for 12 minutes now. Jun 23, 2015 at 11:22
  • @BobBuzzard : you are right and I updated my answer. Only help I can see is either Salesforce fixes the server or let us escape to an other Pod. Right now, no work is possible. Still no direct communication. Still no support. I'm trying to communicate through the AEs responsible for our clients. Their tickets at least won't be closed immediately.
    – Uwe Heim
    Jun 24, 2015 at 11:16
  • My case is being routed to the next tier for further investigation. I'll post more as I hear it. Jun 24, 2015 at 11:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .