2

I have a customer who installed our package in their sandbox and their tests are failing in our namespace (That's just the information that the stacktrace shows).

The weird thing is that their tests are failing even without our apex trigger, I already had a call with them and I was not able to see the whole log due the limit restriction in size.

Our Apex Trigger logic is wrapped in a whole try/catch, so I don't see what else could affect them.

Have you ever seen a similar behavior?

Do you know what else could affect third party tests besides an apex trigger?

Thanks in advance.

Best

1
  • The same happened in our org and we set the SeeAllData = true on each test method which are failing and we can get through test classes passed.
    – Suresh
    Jun 10 '15 at 14:30
2

Triggers, validation rules, lookup filters, and workflow rules (with field updates) are the four most-likely suspects. Triggers can change the values in a record or update related records, and can also cause trigger stack depth errors. Validation rules can cause a record to fail to insert/update. Lookup filters can cause exceptions if the data doesn't match the filter value. Workflow rules can cause triggers to run twice, which may run afoul of governor limits or cause unintended side effects.

2
  • Thanks for you answer, I will investigate with this and I will let you know what happened. Jun 11 '15 at 21:15
  • It seems like our customer was providing us outdated information. Everything is ok now. Despite that, I will accept this question as the most useful one. Thanks. Jun 16 '15 at 20:15
1

By experience, I also had this problem with my user permission (which is a little bit weird). So what I did was I just logged into their user and executed the test cases under their account which somehow solved my problem :)

4
  • The problem is that the tests are failing in their sandbox and with their users. I will see if something related to the user permissions could affect :). Jun 9 '15 at 20:44
  • Best of luck! Keep me posted as I'm genuinely curious on what's causing their error too!
    – dotmiko
    Jun 9 '15 at 20:52
  • It seems like our customer was providing us outdated information for an old patch version, suddenly everything went OK :(. Jun 16 '15 at 20:10
  • I see, well glad it all worked out nonetheless! :)
    – dotmiko
    Jun 16 '15 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.