I installed Adobe Document Cloud into Salesforce in the standard process and then linked the Agreements object with a custom object.

I setup all the merge fields, including:

  • linking the Merge Mappings with the Agreement Template
  • creating a MapData into Agreement Fields link with the Agreement Template
  • Also created a custom Detail Page Button for generating the agreement with merged fields

The PDF I created is about 604MB in size with form fields.

After repeated QA'ing, I keep getting this error in a new window when I click the custom button to generate the agreement:

Update failed. First exception on row 0 with id a0qU000000GIrHWIA1; first error: STRING_TOO_LONG, Error Message: data value too large: Didn't understand relationship 'media_placement__c' in field path. If you are attempting to use a custom relationship, be sure to append the '__r' after the custom relationship name. Please reference your WSDL or the describe call for the appropriate names. (max length=255): [echosign_dev1__ErrorMessage__c]

Here's the apex code that I inserted into the text space:


I double checked to make sure that the ID was the Agreement Template's. Noticed other SF devs are having similar issues with other projects.

How do I generate a merge mapped agreement and resolve this error?

  • 1
    Have you tried to do what the error message said an change it to {!Media_Placement__r.id} or simply {!Media_Placement__c} since the field should be the ID value anyway...The String to long is most likely a fault in the Adobe package that does not check the size of the error message when attempting to store the value.
    – Eric
    Commented Jun 8, 2015 at 4:27
  • Yes, I did try both {!Media_Placement__r.id} and just passing {!Media_Placement__c} and I couldn't save either formula-- salesforce returned syntax errors that claimed 'Field Media_Placement__c does not exist. Check spelling.'
    – GPP
    Commented Jun 8, 2015 at 17:11
  • then the field does not exist as it is typed or you are on the wrong object. Have you tried the advanced editor and picking the field?
    – Eric
    Commented Jun 8, 2015 at 21:48
  • @Eric so this is where I think the disconnect is: the Media_Placement__c is a custom object. It has fields associated with it of course, but which field should I be passing in to actually call eSign to generate the form? For context, that code I entered in the description I copy-pasted from a walkthrough
    – GPP
    Commented Jun 8, 2015 at 22:28
  • @Eric, the error message has been resolved because a field was being incorrectly used in the actual Agreement Template itself. However, when the 'send to esign' button is now clicked, the agreement window loads but the correct template does not, with an error message: Invalid field [custom object api ID] for echosign_dev1__SIGN_Agreement__c Does this error message jump out to you as suggestive of a field/syntax error somewhere in the Agreement Template record?
    – GPP
    Commented Jun 13, 2015 at 1:54

1 Answer 1


An admittedly belated big thanks to all the commenters.

The core formula that I posted in the original Question was correct, but I had been over zealous in checking a check-box related to referenced objects.

The correct code remains:


Just be careful which check-boxes you mark as True ;)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .