3

I have created unmanaged package in sandbox(Enterprise Edition). And link after uploading package in sandbox is like https://test.salesforce.com/packaging...

And I am trying to install it in developer org by modifying package url from https://test.salesforce.com/packaging... to https://login.salesforce.com/packaging...

but it is showing me error like

Mismatch Version

Please help me out.

  • 2
    Is your sandbox on Summer15 already? If it is, and you are trying to install in a normal DE org, it will be a release ahead, and will not install. – pchittum Jun 1 '15 at 10:31
  • Yes it is Summer15. but same package i'm trying to install in another EE production org, same error persist. but it getting installed in another EE sandbox. Why So? – Vrushabh Jain Jun 1 '15 at 11:07
2

We are in a state where some Salesforce instances are on the Summer 15 pre-release, and others on the current Generally Available (GA) release of Spring 15.

Orgs on Summer 15 will be either:

  1. Orgs provisioned through the Summer 15 pre-release signup page.
  2. Sandbox orgs that wen through the early upgrade option.

The former will all be using the gs0.salesforce.com domain. The latter will be on whatever CS instance they were provisioned on.

When you build something in the Summer 15 timeframe (API version 34), your package will use that API version.

If you need to test package install, the easiest way to do this is to provision another pre-release org and attempt the install there.

If you want to get the feature you created into a specific org that is not yet on the new release, there are two possibilities.

  1. If you have used features specific to the new release, you must wait until the GA date.
  2. If you have not used an pre-release features, you can install using one of the many deployment tools by connecting to your pre-release org using the currently GA version and deploying to the other org.
| improve this answer | |
  • I tried to install package from sandbox to production which is on summer 15 only. but still getting same error for production which i found a bit weird. But when I tried in another pre-release org it worked. But why it didn't work in production. – Vrushabh Jain Jun 2 '15 at 6:15
  • 1
    It will, once your production org is on Summer15. You should check trust.salesforce.com to find out the exact date of the upgrade for your instance. – pchittum Jun 2 '15 at 6:59
  • Ohh Yes Release date for production is yet to come and sandbox is already released with summer 15. That's why it is not getting installed in production. – Vrushabh Jain Jun 2 '15 at 7:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.