0

I am trying to encrypt the password using command

encrypt -e mypassword "D:\SFDC_docs\Salesforce-connectivity\try\Key.txt"

but getting error as

" security.EncryptionUtil main (EncryptionUtil.java:289) - Invalid option format: ûe".

I need this to use command line data loader. Please help. Please dont mark it as duplicate as the solutions given in other threads are not working for me.

2
  • 2
    It looks like you mypassword string contains characters that the cmd.exe is interpreting as option strings. First thing to try is to add double quotes i.e. try "mypassword". Or change your password and stick to simple alphanumerics (and make your password longer to compensate security-wise).
    – Keith C
    May 26, 2015 at 8:24
  • try removing dash "-" in front of "-e" and inserting minus instead. If you copy/pasted this from some document then dash in "-e" may not be the "minus" character you think it is. Just remove the whole "-e" thing and type it again.
    – gaiser
    May 27, 2015 at 8:05

2 Answers 2

2

I guess you copy pasted command encrypt.bat -e "C:\temp\key.txt" from some website.

It should be minus sign instead of dash, Can you try to type it and run it. You may find some helping steps here as well.

1
  • 1
    Um, what is the difference between minus sign and dash?
    – Adrian Larson
    Feb 16, 2016 at 22:32
0

I think you must write "encrypt.bat" with extension instead of only "encrypt".

Hope this may help.

2
  • I tried as encrypt.bat -e rrpatil228 "D:\SFDC_docs\Salesforce-FTP_connectivity\try\Key.txt" as well, but giving same error May 26, 2015 at 6:51
  • ok, try adding your security token after your pwd : rrpatil228SECURITYTOKEN
    – Nebula
    May 26, 2015 at 6:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.