0

trying to create an email reference thread id for a custom object. I found the following field formula on the web.

FORMULA

ref:"&LEFT( $Organization.Id , 4)&"0"&RIGHT( $Organization.Id , 4)&"."&LEFT(Id , 4)&"0"&RIGHT(Id , 5)&":ref 

However, when I tried to create the formula field on the custom object, I get the following error message...

"Error: Syntax error. Missing '='".

I'm not sure what that error message means or how to fix it.

1

Try this as the formula

"[ref:_" & LEFT($Organization.Id,5) & SUBSTITUTE(RIGHT($Organization.Id,11), "0", "" ) & "._" & LEFT(Id,5) & SUBSTITUTE(RIGHT(Id,11), "0", "" ) & ":ref]"
2
  • When I try to validate the syntax I get the same error message with the following text highlighted "" & LEFT($Organization.Id,5) & SUBSTITUTE(RIGHT($Organization.Id,11), "" and when I add a "=" after the ref:_, I get the following error message "Error: Syntax error. Missing ']'" and the first "0" referenced is highlighted. Again, kinda at a lost here. BTW, thanks for your response – petyrc May 26 '15 at 21:08
  • Here is what I have, which works - dropbox.com/s/mhctbhitmnam8yz/CaseRef.png?dl=0 - does your setup look different? – MarcDBehr May 28 '15 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.