2

I'm using process builder for the first time and the request to create a record is not working. What am I doing wrong? Here is what I need.

Criteria:

When a record in a custom object (Engagement) is created, an Opportunity is created for a different group.

  1. The Engagement RT is 'XX' and that is the only criteria for the first step.
  2. The Opportunity is created for another team with a record type of 'YY' as soon as the Engagement record is created.

There is no delayed action... I've managed to find the cross referencing fields to use on the Opportunity so there are approximately 8 fields that should populate on the new Opp record. I've made sure to include all the required fields. It isn't that complicated but when I activate it and create an Engagement with XX recortd type, the Opp isn't created. Why? Any ideas?

UPDATE:

Here is the section of the debug... I don't know what to look for since it's the first time I debug on a process flow.

14:54:46.416 (416141972)|WF_FLOW_ACTION_BEGIN|09L180000004DFH
14:54:46.418 (418864360)|FLOW_CREATE_INTERVIEW_BEGIN|00D180000000rOO|300180000008Rvv|301180000008Xe0
14:54:47.065 (1065353084)|FLOW_CREATE_INTERVIEW_END|519824cec140a2e93653279e7c0a14d4e7bf816-55d4|TM Opps from MS Engagements 6
14:54:47.069 (1069512151)|FLOW_START_INTERVIEWS_BEGIN|1
14:54:47.102 (1102873129)|FLOW_START_INTERVIEW_BEGIN|519824cec140a2e93653279e7c0a14d4e7bf816-55d4|TM Opps from MS Engagements 6
14:54:47.112 (1112282868)|FLOW_START_INTERVIEW_END|519824cec140a2e93653279e7c0a14d4e7bf816-55d4|TM Opps from MS Engagements 6
14:54:47.112 (1112308915)|FLOW_START_INTERVIEWS_END|1
14:54:47.116 (1116655087)|WF_FLOW_ACTION_END|09L180000004DFH
14:54:47.116 (1116686142)|WF_TIME_TRIGGERS_BEGIN
14:54:47.123 (1123423701)|WF_ACTIONS_END| Email Alert: 2; Flow Trigger: 1;
14:54:47.123 (1123431117)|CODE_UNIT_FINISHED|Workflow:01I70000000IABR
14:54:47.127 (1127583669)|EXECUTION_FINISHED
4
  • 1
    If the flow is failing it will give you a flow error. If no errors are popping up check to make sure the Criteria is correctly being met. – Dan May 13 '15 at 18:21
  • I've reviewed them many times... and tried more and less information to see if maybe I was trumping myself but it seems to be ok when I review the flow. First step is when record is created. Then the Engagement RT, then create a record. But nothing happens. Should I be using the advanced options? I'm not sure what they mean as this is the first flow I build here. – Heidi May 13 '15 at 18:26
  • Can you post a screen shot of your Process Builder flow? I'm not a debug master but I don't see the record creation even triggering thus it leads back to the criteria to fire that section of the Process doesn't seem to happen. – Dan May 13 '15 at 19:47
  • Hi @Dan! How do I post a screenshot? I am trying but it doesn't post. (Still only one day old on SE. :)) – Heidi May 14 '15 at 12:11
3

Like @Dan pointed out, it sounds like the Process isn't being triggered. If you are using the RecordTypeId in the criteria, make sure you are using the CASESAFEID or the 18 char Id in the criteria.
You could also try using starts with vs equal while using the 15 char Id.

2
  • Hi Jenny! Thanks, I changed the equals to starts with and I'll activate the new flow to see if it works. I'll keep you posted. :) – Heidi May 14 '15 at 12:18
  • IT WORKED!!!!! Yay! @Dan, I used Jenny's suggestion and the record created. :) You guys are the best! Thank you!! – Heidi May 14 '15 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.