We need to send emails to a system that expects a specific email address. This address can be specified by ourselves but it has to be fixed!

Problem is that no matter what I try, the true email sender is not fixed, so it changes all the time. Key question: how can we set a true static outbound email address so the system receive our emails? Clearly you can set "on-behalf of", "reply To" etc... to hide the truth, but the system we need to support sees through this and sees the true email sender which is some sort of floating Salesforce email address that is extremely long.

As you can see here below.

Return-path: <support=company.com__0-478mk2vvgnmprp@y9xpbsk0u0v3usmt.wkuqcd2ai6ix1y22.cksl68h.i-fijdeay.na15.bnc.salesforce.com> Envelope-to: customer@emailadress.com Delivery-date: Tue, 12 May 2015 01:00:00 +0100 Received: from customer.domain.com ([xxx.xxx.xxx.xxx]) by smtp3.customerdomain.com with esmtps

  • Will your system accept a KPID? Perhaps that might solve your issue.
    – crmprogdev
    May 12 '15 at 14:41

According to SFDC docs, I see no way to override and create a static "from" address.

Have you considered whitelisting the IP addresses which these emails are sent from? This way, you can ensure only SFDC emails are received by your external email system. Also, I see IPs as the only predictable and true constant in this use case.


Salesforce sends email from a variety of IP addresses. If your organization blocks any of these IP addresses, users may not receive all email sent from Salesforce. In order to ensure that your organization’s users receive all Salesforce emails, verify that the following 169 IP addresses are whitelisted in your email server firewall.

There's a whole section on email deliverability and security in the link above (near bottom of article).

  • Thx! Unfortunately I have no control of the other end as it is Ebay mail system we are sending emails to.
    – Cluudi
    May 19 '15 at 14:30
  • Sorry to hear. I would recommend you open a SFDC case and talk with support. They may have other options available or tell you the system you are using is not compatible.
    – James
    May 19 '15 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.