1

case sharing pic

I have added case share using manual share(apex programming) and I could see the id from the case share table in debug logs after insert. I have verified everything including users access(community user) and on the object level for the case but not able to see these case share records in caseshare table.

Please let me know what else can I check?

User and Group Sharing

  • Please share some code .Also some info around how are you querying case table ?workbench or developer console ?Are you able to view the case as login to that user with whom you shared – Mohith Shrivastava May 9 '15 at 17:37
  • Do you mean you can't see case share records or case records? – Caspar Harmer May 10 '15 at 20:05
  • I'm facing the same issue. What I wanted to do is to create a caseshare for the case creator. In my code, I didn't specify the Rowcause as recommended. The caseshare is created with an ID according to the Debug Log but on table it doesnt show..Any comment? – user21371 Jun 17 '15 at 4:01
2

Bit late to the party, but since this was the top hit on google when I ran into this issue, I guess it is still relevant.

As per the documentation, all manual shares are removed when the owner changes. This also applies when using auto-assignment rules, which seems to be the case in the example.

Placing the sharing code in an after update trigger solves the issue, as they are run after auto-assignment rules are applied.

Also, upvote this idea if you think this issue should be solved :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.