1

I'm trying to create Ant tasks to make it easier to implement Continuous Integration in the company I work for, and I'm facing one annoying issue when trying to deploy the package to the new org.

  1. objects/Trabalho__c.object (Trabalho__c.Trabalhos_nao_concluidos_na_Sprint_Trabalho) -- Error: This View Unique Name already exists or has been previously used. Please choose a different name. (line 1304, column 16)

I keep getting this error for lots of lists from this same object. I've already tried to edit the custom object, disabling the reports, activities and field history tracking. This solved another problem I had with the deploy for other object, but this error keeps appearing.

Salesforce keeps telling that the view already exists, but the new org is empty and doesn't have the object "Trabalho__c".

Is this a bug, or am I doing something wrong?

  • 1
    Have you switched languages? I have observed that Salesforce sometimes seems to make copies of the standard views, with the name in the other language. I have experienced this myself and it has caused big problems between an org and its sandbox. I could only deploy after much fiddling. – Sander de Jong May 6 '15 at 13:16
  • Actually, yes. However, I tried changing it back, so both orgs had the same language. Also, I found out the error was caused by a sharing rule in the list views. I'm going to update this question with my own answer explaining this better. – Renato Oliveira May 6 '15 at 14:03
1

I figured out this was being caused by a sharing rule in the list view. The object affected had some views with the following tag:

<sharedTo>
        <allInternalUsers></allInternalUsers>
</sharedTo>

Interestingly, I removed those views, and could make the deploy.

I believe this is caused by a legacy feature that Salesforce tries to migrate to the new org. I had similar issues with profile permissions (some permissions don't exist in the newer orgs, but still do in the old ones).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.