As the latest release rolled out we have been unable to connect to our sandbox environment via oAuth. The application login logic has been untouched in months and the keys stored in production are as they were. The login mechanism runs but as the page redirects through its usual pattern we are presented with an SFDC page with the main frame displaying a "Data Not Available" message instead of the usual oAuth screens.

Anyone else seeing this behavior?

  • I was getting the same error this morning trying to connect from workbench to our sandbox(this also uses Oauth), sounds like a bug.
    – PepeFloyd
    Jan 18, 2013 at 22:17
  • Posted the same question on developer.force.com and have some replies showing the same behaviour on cs5, 7, 9 and 12.
    – Autobat
    Jan 18, 2013 at 22:36
  • @PepeFloyd thank you for reminding me! I have just tried workbench and it failed now I have ability to show my friend in tier 3 support how to replicate!
    – Autobat
    Jan 18, 2013 at 22:40
  • Confirmed that this is a far reaching bug but not to many details on it. Speaking with support now and will keep you all posted on any information they give me.
    – Autobat
    Jan 19, 2013 at 1:57
  • Off phone with support again. Confirmed there is something disconnecting Spring 13 to production for the oAuth keys and have worked it through with a number of test instances but no joy on whats causing it.
    – Autobat
    Jan 19, 2013 at 2:46

1 Answer 1


Issue was caused by a defect in Spring 13 where sandbox instances no longer had access to production oAuth keys.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .