0

I'm working in a Salesforce instance with the Exact Target integration installed, and for some reason the unsubscribe, resubscribe and 'Send ExactTarget Email' links on the Contact do not work.

When either unsubscribe or resubscribe is clicked, I get the message:

"The connection to ExactTarget is currently unavailable. Try your request again later. if the problem persists,please contact your system administrator."

Calling Webservice method in the managed package from Execute Anonymous returns "connection error".

The administrator account I'm working in is also an administrator in ExactTarget, and thus should have all necessary permissions. I mention the error with the Send E-mail link because while it is different, it might be related. In that case I am taken to a page which says "Insufficient User Permissions," but again, as far as I can tell the account has full permissions, and is capable of sending e-mails from within ExactTarget.

  • 1
    What is the package version? Does you API user setup within Marketing Cloud (ExactTarget) have 'Grant the user access to the web services' selected? – Mac Apr 27 '15 at 12:21
  • Version 5.35, and yes. – LucidLunatic Apr 27 '15 at 15:08
2

This is usually an issue with the "Field Level Security" for Contacts.

On the first link below, the "Field Level Security" steps are as follows. Once updated, you should see that error no longer:

http://help.exacttarget.com/fr-FR/documentation/integrated_products__crm_and_web_analytic_solutions/exacttarget_salesforce_integration_v5/salesforce_v5_install_guide/v5_package_installation/

https://help.salesforce.com/apex/HTViewHelpDoc?id=customize_layoutoverview.htm&language=en_US

If you continue to see errors after confirming field level security is good, it may be an issue specific to your Stack (if on Stack7). Follow the below steps and see if that resolves your issue.

-In Salesforce, Select Setup 
-Select 'Security Controls' 
-Select 'Remote Site Settings' 
-Find the entry for S7_SOAP 
-Select the Edit options 
-Change the URL value from https://webservice.s4.exacttarget.com to https://webservice.s7.exacttarget.com 
-Click Save 
  • The administrator account, which is the Integration user, along with a few other profiles all have the Email Opt Out field as visible and editable. From testing, I know that unsubscribing from an e-mail list appropriately sets the Email Opt Out box. Are there other fields that I should check on as well? – LucidLunatic Apr 27 '15 at 15:13
  • Do you know what Stack you are on? S7 perhaps? Are you using a custom domain at all? – Jeremy Apr 27 '15 at 18:38
  • s7, no custom domain to my knowledge. – LucidLunatic Apr 27 '15 at 19:15
  • And that was it! Changing the webservice URL value did it. Not sure how it was wrong, since all of that was part of the managed package. But I'm not the one who did the installation, so I'm just happy to have fixed it. Thank you for your help! – LucidLunatic Apr 27 '15 at 19:19
  • Note: this did not resolve the Send ExactTarget E-mail issue, but I don't actually need that working. – LucidLunatic Apr 27 '15 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.