2

I just built a process in Process Builder that isn't behaving as expected. It's firing on a child object in a master-detail, and the criteria is a formula involving fields on both the child and the parent object. The action is a field update on the parent obj (picklist field).

When I test it the field update does not occur.

Looking in debug log, though, it looks like the criteria is evaluating to true. Any idea why the action wouldn't be happening, in that case?

Debug log:

33.0 APEX_CODE,DEBUG;APEX_PROFILING,INFO;CALLOUT,INFO;DB,INFO;SYSTEM,DEBUG;VALIDATION,INFO;VISUALFORCE,INFO;WORKFLOW,INFO 17:19:05.053 (53998607)|EXECUTION_STARTED 17:19:05.054 (54020668)|CODE_UNIT_STARTED|[EXTERNAL]|Workflow:01IJ0000000AUeF 17:19:05.071 (71959972)|WF_RULE_EVAL_BEGIN|Workflow 17:19:05.071 (71982540)|WF_CRITERIA_BEGIN|[Work Party Report: WPR-1 a2KJ0000000Y6kn]|VMS_WP_Status_to_Completed_when_Report_Submitted301J00000000hGW|01QJ00000001TA2|ON_ALL_CHANGES|0 17:19:05.072 (72085557)|WF_FORMULA|Formula:ENCODED:[treatNullAsNull]true|Values: 17:19:05.072 (72092232)|WF_CRITERIA_END|true 17:19:05.072 (72750427)|WF_CRITERIA_BEGIN|[Work Party Report: WPR-1 a2KJ0000000Y6kn]|VMS: Set Travel Time on Work Party|01QJ00000001Pkk|ON_ALL_CHANGES|0 17:19:05.073 (73967309)|WF_FORMULA|Formula:ENCODED:[treatNullAsNull]ISCHANGED( {!ID:00NJ0000001iTRS} )|Values:Total_Admin_Prep_Travel_Hours__c=10 17:19:05.073 (73973235)|WF_CRITERIA_END|false 17:19:05.073 (73988928)|WF_SPOOL_ACTION_BEGIN|Workflow 17:19:05.074 (74008795)|WF_ACTION| Flow Trigger: 1; 17:19:05.074 (74012095)|WF_RULE_EVAL_END 17:19:05.074 (74497316)|WF_FLOW_ACTION_BEGIN|09LJ000000001bm 17:19:05.076 (76067585)|FLOW_CREATE_INTERVIEW_BEGIN|00DJ0000003OYAA|300J000000007oL|301J00000000hGW 17:19:05.077 (77512729)|FLOW_CREATE_INTERVIEW_END|84945228a7ca7446766464e663f914cedd0822a-74d8|VMS: WP Status to Completed when Report Submitted 17:19:05.078 (78440250)|FLOW_START_INTERVIEWS_BEGIN|1 17:19:05.079 (79948413)|FLOW_START_INTERVIEW_BEGIN|84945228a7ca7446766464e663f914cedd0822a-74d8|VMS: WP Status to Completed when Report Submitted 17:19:05.081 (81373905)|FLOW_START_INTERVIEW_END|84945228a7ca7446766464e663f914cedd0822a-74d8|VMS: WP Status to Completed when Report Submitted 17:19:05.081 (81394726)|FLOW_START_INTERVIEWS_END|1 17:19:05.083 (83107587)|WF_FLOW_ACTION_END|09LJ000000001bm 17:19:05.083 (83169103)|WF_ACTIONS_END| Flow Trigger: 1; 17:19:05.083 (83173714)|CODE_UNIT_FINISHED|Workflow:01IJ0000000AUeF 17:19:05.084 (84670704)|EXECUTION_FINISHED

  • Huh. I thought that the WF_CRITERIA_END|true in the log meant the process criteria was met. But I tried it again and put in something that patently doesn't meet the criteria, but I still see WF_CRITERIA_END|true in the debug log for this process. Huh? – mscholtz Apr 25 '15 at 0:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.