2

In the organisation, there is a call center definition file that loads a softphone component. When debugging it with IE10, I can see the softphone adapter is loaded twice. It happens in Console mode, but not in Sidebar mode. It does not either happen when I activate the "Cache > Always refresh from server".

Softphone and call center definition files:

<!DOCTYPE html>
<html>
  <head>
    <meta http-equiv="cache-control" content="max-age=0" />
    <meta http-equiv="cache-control" content="no-cache" />
    <meta http-equiv="expires" content="0" />
    <meta http-equiv="expires" content="Tue, 01 Jan 1980 1:00:00 GMT" />
    <meta http-equiv="pragma" content="no-cache" />
    <title>Child Frame</title>
    <script>window.alert("hei ho");</script>
  </head>
  <body>
      alskdjf alskdjf asldkf
  </body>
</html>
<callCenter>
    <section sortOrder="0" name="reqGeneralInfo" label="General Information">
        <item sortOrder="0" name="reqInternalName" label="InternalName">consoleTest</item>
        <item sortOrder="1" name="reqDisplayName" label="Display Name">console test</item>
        <item sortOrder="2" name="reqDescription" label="Description"/>
        <item sortOrder="3" name="reqUseApi" label="Use CTI API">true</item>
        <item sortOrder="4" name="reqAdapterUrl" label="Adapter URL">https://server/files/testGadget.html</item>
        <item sortOrder="5" name="reqSoftphoneHeight" label="Softphone Height">500</item>
        <item sortOrder="6" name="reqSoftphoneWidth" label="Softphone Width">300</item>
    </section>
</callCenter>

In the softphone, I tried to disable the cache in several ways, without success. When the code above is loaded in the console, it triggers the alert twice.

Is there a feasible way to disable the softphone iframe cache?

Browser: IE10 SF: Spring'15 - Partner Developer Edition OS: Windows 7

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.