0

I am running into an issue where every time I deploy to my org with the ANT tool the output is flooded with unit test debug logs. I have added logType="None" to the build.xml which doesn't help.

I suspect it is an actual org setting as it has become an issue just recently.

Here is an example of how it used to look:

 [sfdeploy] Request for a deploy submitted successfully.
 [sfdeploy] Request Id for the current deploy task: 04sj000000EbXSiAAN
 [sfdeploy] Waiting for server to finish processing the request...
 [sfdeploy] Request Status: Completed
 [sfdeploy] Finished request 04sj000000EbXSiAAN successfully.

BUILD SUCCESSFUL
Total time: 36 seconds

This is how it looks now:

[sfdeploy] Request Status: Succeeded
[sfdeploy] Debugging Information:
[sfdeploy] 29.0 APEX_CODE,ERROR
[sfdeploy] 16:15:09.800 (71800868246)|EXECUTION_STARTED
[sfdeploy] 16:15:09.800 (71800890226)|CODE_UNIT_STARTED|[EXTERNAL]|xxxxx|Approvals_Test.xxxxx
[sfdeploy] 16:15:09.851 (71851467309)|CODE_UNIT_STARTED|[EXTERNAL]|Validation:Account:new
etc etc etc

Here is the ant target

    <target name="deployqa">
            <property file="build.properties"/>
            <taskdef
                name="sfdeploy"
                classname="com.claimvantage.force.ant.DeployWithXmlReportTask"
                classpathref="ant.additions.classpath"
                />
            <delete dir="test-report-xml" quiet="true"/>

            <antcall target="zipStaticResourcesFolder">
             </antcall>
            <sfdeploy username="${sf.username}" password="${sf.password}" 
                      serverurl="${sf.serverurl}" deployRoot="xxxx" runalltests="false" logType="None" 
                      junitreportdir="test-report-xml" pollWaitMillis="30000">
                <!-- Run only tests with file names that match this pattern -->
                <batchtest>
                    <fileset dir="xxxx">
                        <include name="*Test.cls"/>
                    </fileset>
                </batchtest>
            </sfdeploy>
        </target>

Any help is appreciated

4
  • I'm not sure, could classname="com.claimvantage.force.ant.DeployWithXmlReportTask" define some kind of functionality that could be causing this? Apr 17, 2015 at 17:55
  • I will try without that, but I don't believe it is the cause because nothing in the build.xml has changed in months and the issue just started a week or so ago.
    – Scott Reed
    Apr 17, 2015 at 18:01
  • Try adjusting the logging levels for your deployment user in salesforce then. salesforce.stackexchange.com/questions/5097/… Apr 17, 2015 at 18:05
  • I did this and unfortunately there is no change.
    – Scott Reed
    Apr 17, 2015 at 21:28

1 Answer 1

1

add the logType="None" parameter to the sfdeploy. Valid options are None, Debugonly, Db, Profiling, Callout, and Detail

3
  • I posted the ant target above, i'm already using logType="None". I thought this would be the solution but it wasnt
    – Scott Reed
    Apr 17, 2015 at 20:39
  • Oh awkward... haha For what it's worth, I've been having some reliability issues with that claimvantage package. Whenever it feels like it (read: most of the time), it will stop producing test output, and I notice that the logging output (like what you're seeing) is actually elevated during runs which do not output test results Apr 21, 2015 at 14:00
  • I redirect that to a file with redirection . you can use it based on your OS. ANT deployQA > log.txt Jun 9, 2017 at 1:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .