3

When I try to create an Import Definition with the Ruby Fuel-SDK I get the following error message:

"Select the appropriate destination for a Destination Type of Data Extension"

The properties that I'm using to create the Import are:

{"Name"=>"Table", "CustomerKey"=>"...", "Description"=>"Created with Ruby SDK", "AllowErrors"=>"true", "DestinationObject"=>{"ObjectID"=>"..."}, "FieldMappingType"=>"InferFromColumnHeadings", "FileSpec"=>"Table.csv", "FileType"=>"CSV", "RetrieveFileTransferLocation"=>{"CustomerKey"=>"..."}, "Notification"=>{"ResponseType"=>"email", "ResponseAddress"=>"email@email.com"}, "UpdateType"=>"Overwrite"}

Anyone has had a similar problem?

Edit:

When I run the specified code I get:

Code log

  • That can happen if the Savon version isn't 2.2.0. The SDK doesn't support newer versions at this time. – Mac Apr 14 '15 at 14:55
  • Thanks @mac , I've checked and the version of Savon that is installed locally is the 2.2.0 – exact_target_user Apr 14 '15 at 14:59
  • If I run that I get: – exact_target_user Apr 14 '15 at 15:09
  • I've updated the question with the log that I get when I run the code you've just given me. – exact_target_user Apr 14 '15 at 15:15
  • When I click the link for the code log, it appears blank, is that what you are seeing? – Mac Apr 14 '15 at 15:17
0

What is the output if you run the following in your environment:

require 'savon'
p Gem.loaded_specs["savon"].version

If that shows the gem is 2.2.0 then that isn't the issue. Sometimes the gem version being used is confusing so this is the best way to check.

I believe the real answer to this question is that the wrong identifier was used. The ObjectID being specified for the Data Extension is a system generated GUID which is not the same as the CustomerKey/ExternalKey which is the unique identifier that can be set at the time the data extension is created. It is called CustomerKey in the API and External Key if looking in the UI but the value is the same.

It gets confusing because if a value is not provided for CustomerKey/ExternalKey then the system generates a GUID for this field but it is not the same as the GUID generated for the ObjectID. The ObjectID can be looked up for a data extension by performing a retrieve through the API or the code can be updated to use CustomerKey instead to resolve this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.